Discussions

Expand all | Collapse all

Button for subscription not sending report

  • 1.  Button for subscription not sending report

    Posted 14 days ago
    I am using Formula rich text to try and create a button that will send a subscription report that is in a different table in the same app.....  However, it is only taking me to the subscription report settings where I can send myself a "Test e-mail" but I'm looking for the button to automatically send the subscription report (I understand there is few minutes delay potentially).

    This is my formula currently....

    "<a class=\"Vibrant Primary\" style=\"width:310px; text-align: center;\" href=\"/db/"&"(MY OTHER TABLE ID INSERTED HERE)"&"?a=GenPeriodicReportEdit&id=1\">SEND REPORT</a>"

    Jeff Elliott

    ------------------------------
    Jeff Elliott
    ------------------------------


  • 2.  RE: Button for subscription not sending report

    Posted 14 days ago
    try this

    "<a class=\"Vibrant Primary\" style=\"width:310px; text-align: center;\" href=\"/db/"&"(MY OTHER TABLE ID INSERTED HERE)"&"?a=sendsubscription&id=1\">SEND REPORT</a>"


    ------------------------------
    Mark Shnier (YQC)
    Quick Base Solution Provider
    Your Quick Base Coach
    http://QuickBaseCoach.com
    mark.shnier@gmail.com
    ------------------------------



  • 3.  RE: Button for subscription not sending report

    Posted 13 days ago
    Dear Mark:

    That worked like a charm!  Any advice on how to have the same button send a 2nd, separate report?  

    Jeff

    ------------------------------
    Jeff Elliott
    ------------------------------



  • 4.  RE: Button for subscription not sending report

    Posted 13 days ago
    Not tested but try this as a new field of type formula URL (not Formula Rich Text).

    var text SendSubOne  = URLRoot() & "db/" & [_DBID_ MY OTHER TABLE ID INSERTED HERE]
    & "?a=sendsubscription&id=1";

    var text SendSubTwo  = URLRoot() & "db/" & [_DBID_ MY OTHER TABLE ID INSERTED HERE]
    & "?a=sendsubscription&id=2";

    $SendSubOne
    & "&rdr=" & URLEncode($SendSubTwo)

    I would just make this as URL formula field type instead of a Formula Rich text field as then you do not need the difficult syntax.



    ------------------------------
    Mark Shnier (YQC)
    Quick Base Solution Provider
    Your Quick Base Coach
    http://QuickBaseCoach.com
    mark.shnier@gmail.com
    ------------------------------



  • 5.  RE: Button for subscription not sending report

    Posted 13 days ago
    Worked great!  thanks Mark, Jeff.

    ------------------------------
    Jeff Elliott
    ------------------------------