Discussions

Expand all | Collapse all

Summary Report not providing total

  • 1.  Summary Report not providing total

    Posted 03-12-2020 16:30
    I think this might be the problem:  I am using fields with a formula - All of the REV. fields are formula fields.  They are totaling correctly.  However, the "TOTAL FOR CK DATE" field is not totaling.  The formula in that field adds all of the REV. fields.
    Table
    Please advise.  Thank you


    ------------------------------
    Lynne8817 Lynne8817
    ------------------------------


  • 2.  RE: Summary Report not providing total

    Posted 03-12-2020 16:36
    Typically that will happen if the formula  for any of your REV fields allows any of the resulting calculations to calculate to null (blank).  So the proper fix is to adjust those calculated fields to calculate to zero as a last resort in the IF statement.  This can also happen if these [Rev...] fields depend on summary fields where you have not set the "Treat blank as zero" to checked.

    The untidy way (imho) is to do this in your [TOTAL FOR CK DATE]

    Nz([Rev field 1]) + Nz([Rev field 2]) ...... + Nz([Rev field last])

    The Nz() function tells the system to use zero if the value is null (blank).  I try to avoid cluttering up the whole app with Nz()s in the formuals preferring to fix them properly at the source.


    ------------------------------
    Mark Shnier (YQC)
    Quick Base Solution Provider
    Your Quick Base Coach
    http://QuickBaseCoach.com
    mark.shnier@gmail.com
    ------------------------------



  • 3.  RE: Summary Report not providing total

    Posted 03-14-2020 13:13
    Thanks...I went through and added the Nz to all involved fields.  it works now!

    ------------------------------
    Lynne8817 Lynne8817
    ------------------------------



  • 4.  RE: Summary Report not providing total

    Posted 03-13-2020 09:06
    Did you double check your field type to make certain it is numeric? No typos in your formula? I have accidentally selected a formula field of text type when I meant numeric before.

    ------------------------------
    Adam Keever
    ------------------------------



  • 5.  RE: Summary Report not providing total

    Posted 05-11-2020 15:47
    Could there be another reason why a currency column isn't totaling? I have the formula below, and it totals in my report. But when I create a summary field against it in a related table, it does not total in reports. 

    I made sure that all fields being referenced are the same type (currency) and have this checked: Treat blank values as "0" in calculations.

    Case([Pricing Type],"Bid", Nz([Original Bid Amount]), "Budget", Nz([Budget Amount]), 0)​


    ------------------------------
    Samantha Sand
    ------------------------------



  • 6.  RE: Summary Report not providing total

    Posted 05-11-2020 18:16
    Is that Summary field set to show totals?

    ------------------------------
    Mark Shnier (YQC)
    Quick Base Solution Provider
    Your Quick Base Coach
    http://QuickBaseCoach.com
    mark.shnier@gmail.com
    ------------------------------



  • 7.  RE: Summary Report not providing total

    Posted 05-13-2020 12:07
    It is!


    ------------------------------
    Samantha Sand
    ------------------------------



  • 8.  RE: Summary Report not providing total

    Posted 05-13-2020 12:13
    Can I see a screen shot showing where it does not total?

    ------------------------------
    Mark Shnier (YQC)
    Quick Base Solution Provider
    Your Quick Base Coach
    http://QuickBaseCoach.com
    mark.shnier@gmail.com
    ------------------------------



  • 9.  RE: Summary Report not providing total

    Posted 05-13-2020 12:35


    ------------------------------
    Samantha Sand
    ------------------------------



  • 10.  RE: Summary Report not providing total

    Posted 05-13-2020 12:36
    I also made a spreadsheet to summarize my four relevant fields to make sure settings are consistent.



    ------------------------------
    Samantha Sand
    ------------------------------



  • 11.  RE: Summary Report not providing total

    Posted 05-13-2020 13:10
    Well I can't explain it but I recreated the report from scratch with the same exact definition and now my summary field totals! 

    Possible corruption in the first report..? I recall when I worked in Lotus Notes, sometimes a component would get corrupted after being modified/saved too many times, and start to misbehave.

    Thanks for your help!

    ------------------------------
    Samantha Sand
    ------------------------------



  • 12.  RE: Summary Report not providing total

    Posted 05-13-2020 13:11
    Ok so we take the success and move in. Crazy.

    ------------------------------
    Mark Shnier (YQC)
    Quick Base Solution Provider
    Your Quick Base Coach
    http://QuickBaseCoach.com
    mark.shnier@gmail.com
    ------------------------------



  • 13.  RE: Summary Report not providing total

    Posted 05-13-2020 13:14
    Thanks!

    ------------------------------
    Samantha Sand
    ------------------------------