Discussions

Expand all | Collapse all

Autofill Lookup Field

  • 1.  Autofill Lookup Field

    Posted 01-09-2020 14:56
    Hey All,

    Hoping someone might be able to help me here.   I am trying to create a notification for an event registration form.  After the form is saved, the person should receive the iCal in an email.

    All works well except the iCal doesn't email correctly.  It comes across as Blank subject, blank location from 2-3pm  (Should have name and location from 8a-5p.)

    Ideas?

    ------------------------------
    Erik Pye
    ------------------------------


  • 2.  RE: Autofill Lookup Field

    Posted 01-09-2020 15:16
    Edited by Austin K 01-09-2020 15:16
    Those fields are populated with data on the record that is having this issue? Does the iCal send blank for subject and location and 2-3pm no matter what you fill out on the record?

    What type of fields are using for your Start and End time fields in the iCal?

    How is everything set up in your app? The user finishes the form, saves, and then the iCal is emailed to them automatically? Or a user downloads and sends it?


  • 3.  RE: Autofill Lookup Field

    Posted 01-09-2020 16:11
    It is currently set up as a relationship with an Events table (One event has many registrations)   The event page has the iCal in question.  If I download the iCal from the Events table it has all the information correct.

    Start and end times are Date/Time fields

    I have it set as an automatic notification.  The user fills out the form, clicks save, and it then gets an email, which is where it gets funky.   If I go back to the registration table, the iCal is there and has the correct info as well.   

    Just can't figure out where the thing goes wonky.

    ------------------------------
    Erik Pye
    ------------------------------



  • 4.  RE: Autofill Lookup Field

    Posted 01-09-2020 16:44
    Edited by Austin K 01-09-2020 16:58
    So you are emailing the iCal field in a regular QuickBase notification? As in just putting the field in the Custom Message like [my iCal field]? I just tested this myself and my subject worked fine. My dates were correct, but my times were not until I set them properly. Once I set them correctly in the field it worked for me when the iCal was emailed.

    How are your Date/Time fields set up? Are they a formula of some sort? Do you manually enter these? The date is easy to set in there but the time isn't as straight forward as it just leaves you a blank space there. 


    Also, are you doing a lookup of the ical field anywhere? I would avoid that at all costs. That is where I am getting errors with this. I would send your notification from wherever the iCal field exists, do not look that up. What you need to do is look up the fields you need for your iCal to one central place and then create the iCal there imo.


  • 5.  RE: Autofill Lookup Field

    Posted 01-10-2020 08:18
    Thanks Austin,

    I do have the iCal field returning as part of a lookup; that must be where the funk is coming in.

    I am going to try to set up the notification from the original table and we'll see how that goes.

    ------------------------------
    Erik Pye
    ------------------------------



  • 6.  RE: Autofill Lookup Field

    Posted 01-10-2020 12:10
    So I am not sure which fix actually made it work, but it is perfect now.  Whatever you said definitely inspired me to get a fix.  I think I was a little frustrated so just started clicking.

    Thanks again Austin.

    ------------------------------
    Erik Pye
    ------------------------------