Discussions

Expand all | Collapse all

IOL Code Page Lines Sometimes Work?

  • 1.  IOL Code Page Lines Sometimes Work?

    Posted 26 days ago
      |   view attached
    I have a code page being injected into my form using iol technique with multiple lines and they are inconsistently working. If I load the page, maybe half of the code is working. Then, if I reload the page, all of it is working; then, i reload again, and none of it is working. Is there something in my code or not in my code that is making this perform irregularly? The code is to make my form look better. Here it is below:

    $("#sect_s1").css("backgroundColor", "#4cc417");
    $("table#sect_s5 tr td").css("border-color", "#EBDDE2");
    $("table#sect_s7 tr td").css("border-color", "#00fa9a");
    $("table#sect_s15 tr td").css("border-color", "#714a97");
    $("table#sect_s17 tr td").css("border-color", "#ff6a6a");
    $("table#sect_s30 tr td").css("border-color", "#4cc417");
    $("table#sect_s18 tr td").css("border-color", "#00fa9a");
    $("#formContents .sectionDiv .Divider").css({backgroundImage: "url()"});
    $("#sect_s4").css("backgroundColor", "#519ef2");
    $("#sect_s12").css("backgroundColor", "#FFD700");
    $("#sect_s5").css("backgroundColor", "#EBDDE2");
    $("#sect_s15").css("backgroundColor", "#714a97");
    
    $("#sect_s30").css("backgroundColor", "#4cc417");
    $("#sect_s2").css("backgroundColor", "#82cafa");
    $("#sect_s3").css("backgroundColor", "#f9966b");
    $("#sect_s17").css("backgroundColor", "#ff6a6a");
    $("#sect_s7").css("backgroundColor", "#00fa9a");
    $("#sect_s18").css("backgroundColor", "#00fa9a");
    $("#sect_s1,#sect_s7,#sect_s18,#sect_s4,#sect_s5,#sect_s12,#sect_s2,#sect_s15,#sect_s30,#sect_s3,#sect_s17").css("border-radius", "25px");
    $("#sect_s1,#sect_s7,#sect_s18,#sect_s4,#sect_s5,#sect_s12,#sect_s2,#sect_s15,#sect_s30,#sect_s3,#sect_s17").css("padding", "20px");


    All it does it remove certain lines or items and then add different colors with rounded padded borders. I've attached a picture. If I paste this in the console - it all works every time, but if it is in a code page - it works sometimes. Every page reload produces a different result. 

    Please help!
    Thanks,

    ------------------------------
    Jordan McAlister
    ------------------------------


  • 2.  RE: IOL Code Page Lines Sometimes Work?

    Posted 26 days ago
    Have you tried clearing your cache to see if that has any effect on the loading of your code page? I have seen some odd behavior before from caching issues.

    ------------------------------
    Adam Keever
    ------------------------------



  • 3.  RE: IOL Code Page Lines Sometimes Work?

    Posted 26 days ago
    Just tried and the first page load showed only half of the sections changed

    ------------------------------
    Jordan McAlister
    ------------------------------



  • 4.  RE: IOL Code Page Lines Sometimes Work?

    Posted 25 days ago
    Hi Jordan,

    I'm curious what are you trying to solve for with this IOL injection? Is there something specific you are looking to create with this different form (like lining up to a business process) or is it a more cosmetic use case?

    ------------------------------
    Evan Martinez
    Community Marketing Manager
    Quick Base
    ------------------------------



  • 5.  RE: IOL Code Page Lines Sometimes Work?

    Posted 25 days ago
    it is more of a cosmetic use case

    ------------------------------
    Jordan McAlister
    ------------------------------