Discussions

Expand all | Collapse all

Abort Save but button link to a different form not working

  • 1.  Abort Save but button link to a different form not working

    Posted 24 days ago
    When an employee is accessing the expense report app for the first time, we do not allow them to create/save an expense form until we set them up in the AP system. Since they don't have a 'vendor#', the app will not allow them to create/save the record. The 'Abort Save' works, but at that time we would like them to send us address information. On the expense report form there is a button to link to a 'new address' form in another table. It works for employees already set up with a vendor# (in case they need to give us a new address), but it doesn't work for employees without a vendor #.  Is this because the form itself is unable to be saved, so therefore, the button to switch to another form won't work?​

    I can move the button back to the dashboard, but would prefer to keep them on the 'add expense report' form if possible, as it will seem less awkward. Please let me know if there is a solution for this, or something I might be overlooking.

    ------------------------------
    Amy Gosz
    ------------------------------


  • 2.  RE: Abort Save but button link to a different form not working

    Posted 24 days ago
    Amy,

    Is the "New Address"  a customer Button that you built?   Please share the code in it.


    ------------------------------
    Don Larson
    Paasporter
    Westlake OH
    ------------------------------



  • 3.  RE: Abort Save but button link to a different form not working

    Posted 23 days ago
    Hi Amy,

    On your Address table is there a vendor number field that is required in order to save a record? What might be happening when they push that button is it might be prompting them to save the record they are currently on in a pop up, and then when they try they get the can't save this record warning message because they don't have the required information on the expense report form and that interrupts them being redirected. I would suggest testing this flow with a user who doesn't have a number yet and see if that is what they are running into. If it is moving the button back to the dashboard might be helpful since it won't run into that snag.

    ------------------------------
    Evan Martinez
    Community Marketing Manager
    Quick Base
    ------------------------------



  • 4.  RE: Abort Save but button link to a different form not working

    Posted 23 days ago
    The Address Table does not require the Vendor ID#, but the expense report does so that won't be saved. There is no information from the expense report to be passed to the Address Table add form. I just want that to be a link directly to that add record form.​

    ------------------------------
    Amy Gosz
    ------------------------------



  • 5.  RE: Abort Save but button link to a different form not working

    Posted 23 days ago
    Hi Amy,

    That most likely means they are getting that redirect warning that ask them to save their current record on the expense report table before going to another page and then if they agree they get the error message that they can't save the expense report due to not having that number. I think based on the default behavior in QB they are going to run into that pop up on a button doing a redirect that sits on that expense report form if they started editing there natively.

    ------------------------------
    Evan Martinez
    Community Marketing Manager
    Quick Base
    ------------------------------