Discussions

Expand all | Collapse all

6� bug

  • 1.  6� bug

    Posted 10 days ago
    When a mobile user types a quote (") or an apostrophe ('), depending on the mobile device, QuickBase enters a text code/string instead of the quote/apostrophe. I haven't fully tested, but a good example is apple devices typing an apostrophe get converted to "6&#65533"

    Have other people experienced this, and has anyone come up with a solution or work around? Or just tell mobile users not to use quotes.....

    ------------------------------
    Mike Tamoush
    ------------------------------


  • 2.  RE: 6� bug

    Posted 9 days ago
    Mike,

    I have run into this with various "special" (very common) characters entered on Apple devices, though I don't recall exactly what characters were affected in addition to quotes. I believe it has to do with how Apple encodes some characters. Interestingly, the conversion of quotes and apostrophes I've seen gives a different text string than yours (see below). Our users are using iPads to collect the data, perhaps different devices encode the characters differently. Just something to keep an eye on in case you see multiple conversion strings for the same characters within your applications.

    I have a solution that, while not fixing the source of the issue, works for our purposes. If you are importing the data, do not display the imported field containing the converted characters. Create a second field that has a formula to SearchAndReplace() the converted text back into the intended characters. If you have multiple characters you need to replace, you can nest multiple instances of this formula inside itself. Of course, if you have multiple fields that include these special characters, you will need the same number of "correction" fields.

    I've included an example of one of my formulas below. If any of your conversion strings also contain special characters like mine did, I suggest copying and pasting the string directly from your field instead of trying to insert the characters manually, as for some reason it doesn't always recognize the match otherwise.

    var text corrected =
    SearchAndReplace(
         SearchAndReplace(
              SearchAndReplace([Imported Text Field],"’","'"),
         "”","\""),
    " ,","");

    ------------------------------
    Oana Toma
    ------------------------------



  • 3.  RE: 6� bug

    Posted 9 days ago
    I forgot I had also put in a support case several months ago for this same issue. We were exporting our data from our data collection application to .csv, then importing that into QuickBase. The character conversion was happening in the iPad-to-csv process. 've included the relevant portion of the support response I received below. I opted to use the workaround I described before for my particular case and did not test out the suggested approach, but you might want to give this a try.

    Response from Support rep:
    "Sometimes when data is copied over from programs such as Microsoft Word, there are a variety of situations where text that is pasted into Quick Base from Microsoft Word and can have unexpected consequences. Here are a few known issues:

    Single and Double Quotation Marks: Microsoft Word automatically changes straight quotation marks ( ' or " ) to curly (smart or typographer's) quotes as you type. These smart quotes are not rendered in custom QuickBase emails and have been linked to other problems. Notepad also honors these special characters.

    Workaround: Type the quotes directly into Quick Base using your keyboard OR you can turn off the auto-correct feature in Microsoft Products for quotation marks. This will prevent your quotes from being turned into special characters. I figured I would share that info incase this pertains to your issue. Instructions are found here: https://support.office.com/en-us/article/Change-curly-quotes-to-straight-quotes-and-vice-versa-017963a0-bc5f-486b-9c9d-0ec511a8fb8f"

    ------------------------------
    Oana Toma
    ------------------------------



  • 4.  RE: 6� bug

    Posted 9 days ago
    Thanks for all the suggestions. I also got this feedback from support regarding iOS devices. I have not tested, but sounds like it all fits the pattern and would work.

    "Smart Punctuation is an iOS feature that automatically turns certain generic punctuation marks like straight quotes into better ones like curly quotes. The problem is that smart punctuation doesn’t always play nice with the internet.

    Go to Settings>General>Keyboard. In the keyboard window click on the text tab (if applicable). In this window, on the right, is an option to use smart punctuation. Turn that smart punctuation option off so that the icon is no longer green. Your quotes will now show up as they should and should also resolve the quotations coming through as question marks."

    ------------------------------
    Mike Tamoush
    ------------------------------