Discussions

Expand all | Collapse all

Error in Formula URL ... Need help

  • 1.  Error in Formula URL ... Need help

    Posted 29 days ago
    I am getting the following error when I click my Formula URl button,Please, what am I doing wrong:

    <qdbapi>
    <action>API_EditRecord</action>
    <errcode>30</errcode>
    <errtext>No such record</errtext>
    <errdetail>Missing "rid" parameter.</errdetail>
    </qdbapi>

    Formula:
    var text urlone = If([Notify Acquisitions Team]<>"Yes",URLRoot() & "db/" & Dbid() & "?a=API_EditRecord" &
    "&rid=" & [Record ID#] &
    "&_fid_15=Yes");
    var text urltwo = "&rdr=" &
    URLEncode(URLRoot()&[_DBID_LEADS]&"?a=Showpage&pageID=18")
    ;

    $urlone & $urltwo


    ------------------------------
    George Bramhall
    ------------------------------


  • 2.  RE: Error in Formula URL ... Need help

    Posted 29 days ago
    I believe that you were trying to click a URL button on a record that has not yet been saved. If the record has not yet been saved, then the Record ID will be equal to null.

    So I suggest just showing this button in view mode on the record.

    ------------------------------
    Mark Shnier (YQC)
    Quick Base Solution Provider
    Your Quick Base Coach
    http://QuickBaseCoach.com
    mark.shnier@gmail.com
    ------------------------------



  • 3.  RE: Error in Formula URL ... Need help

    Posted 29 days ago
    Edited by George Bramhall 29 days ago
    Hi Mark,
    I actually do need to save some other edits before getting redirected. Isn't their a save record before redirecting function?
    Thanks
    G

    ------------------------------
    George Bramhall
    ------------------------------



  • 4.  RE: Error in Formula URL ... Need help

    Posted 29 days ago
    If the user is already in add mode just have them check the checkbox manually.  But no, there is not an easy way to save the record, capture the rid and execute the URL.

    ------------------------------
    Mark Shnier (YQC)
    Quick Base Solution Provider
    Your Quick Base Coach
    http://QuickBaseCoach.com
    mark.shnier@gmail.com
    ------------------------------



  • 5.  RE: Error in Formula URL ... Need help

    Posted 29 days ago
    Most importantly I need to redirect the user to a special page after saving. If the savebeforenavigating functionality won't work here is there any way that can just get redirected to this page after saving? Maybe I can use a form rule to accomplish the checkbox change.

    ------------------------------
    George Bramhall
    ------------------------------



  • 6.  RE: Error in Formula URL ... Need help

    Posted 29 days ago
    If you just have a button to navigate away from the record, and you have the table Advanced Properties set to save before navigating away, then it should save just with this

    URLRoot() & "db/" & AppID() & "?a=Showpage&pageID=18"

    ------------------------------
    Mark Shnier (YQC)
    Quick Base Solution Provider
    Your Quick Base Coach
    http://QuickBaseCoach.com
    mark.shnier@gmail.com
    ------------------------------



  • 7.  RE: Error in Formula URL ... Need help

    Posted 29 days ago
    Mark,

    Correct me if I am wrong, but I believe the new class="SaveBeforeNavigating" in combination with the new %%rid%% can now grab the new record ID and use it for redirects? I'll have to go back and look for the literature on this, it was in one the past few release notes.

    ------------------------------
    Mike Tamoush
    ------------------------------



  • 8.  RE: Error in Formula URL ... Need help

    Posted 29 days ago
    True, maybe in theory but everyone on the forum seemed to fail to get it working for this kind of use case and I was not going to spend 2 hours trying to get it to work.  :)  Maybe you want to impress us all and get it to work!

    ------------------------------
    Mark Shnier (YQC)
    Quick Base Solution Provider
    Your Quick Base Coach
    http://QuickBaseCoach.com
    mark.shnier@gmail.com
    ------------------------------



  • 9.  RE: Error in Formula URL ... Need help

    Posted 29 days ago
    Hi Mark,
    I am glad you didn't waste your time with savebeforenavigate here because your simple solution to use showpage and doing the  record edit with a dynamic rule was the easiest and best solution here.
    Thanks.

    ------------------------------
    George Bramhall
    ------------------------------