Discussions

Expand all | Collapse all

Problems with if statement in User Formula field

  • 1.  Problems with if statement in User Formula field

    Posted 22 days ago
    Edited by Matt Makris 22 days ago
    I am trying to use an if statement in a user formula field and it doesn't seem to be working. It is designed to determine whether a checkbox is checked, then outputs a user field value based on the condition.

    If ([my checkbox]=true,
      [user field A],
      [user field B (via relationship)]
    )


    I am getting the following error with the field in the else output highlighted:
    "expecting text but found user"

    Any ideas?


    ------------------------------
    Matt Makris
    ------------------------------


  • 2.  RE: Problems with if statement in User Formula field

    Posted 22 days ago
    Change the field type to formula user and it now seems to be a formula text field type.

    ------------------------------
    Mark Shnier (YQC)
    Quick Base Solution Provider
    Your Quick Base Coach
    http://QuickBaseCoach.com
    mark.shnier@gmail.com
    ------------------------------



  • 3.  RE: Problems with if statement in User Formula field

    Posted 22 days ago
    That's the confusing part - it already is a user field:



    ------------------------------
    Matt Makris
    ------------------------------



  • 4.  RE: Problems with if statement in User Formula field

    Posted 22 days ago
    It must be mismatched field types within the IF.  What field type is [Assigned to2].  It must be a text field type.


    ------------------------------
    Mark Shnier (YQC)
    Quick Base Solution Provider
    Your Quick Base Coach
    http://QuickBaseCoach.com
    mark.shnier@gmail.com
    ------------------------------



  • 5.  RE: Problems with if statement in User Formula field

    Posted 22 days ago
    Both fields are "Formula - User" type:




    ------------------------------
    Matt Makris
    ------------------------------



  • 6.  RE: Problems with if statement in User Formula field

    Posted 22 days ago
      |   view attached
    It's strange and doesn't really make sense. Check out the screen video I attached.

    ------------------------------
    Matt Makris
    ------------------------------



  • 7.  RE: Problems with if statement in User Formula field

    Posted 22 days ago
    The field in the formula box is called [Assigned to2] and not [Assigned to (calculated)]

    What field type is [Assigned to2]?

    ------------------------------
    Mark Shnier (YQC)
    Quick Base Solution Provider
    Your Quick Base Coach
    http://QuickBaseCoach.com
    mark.shnier@gmail.com
    ------------------------------



  • 8.  RE: Problems with if statement in User Formula field

    Posted 22 days ago
    Mark, [Assigned to2] is a text field. You can see in the picture in the first post. Your first instinct about mismatched fields is correct.

    ------------------------------
    Mike Tamoush
    ------------------------------



  • 9.  RE: Problems with if statement in User Formula field

    Posted 22 days ago
    Edited by Matt Makris 22 days ago
    Thanks Mike. I had my fields named too similarly at one point. Thanks for your time answering that and I will be more careful next time before posting :)

    ------------------------------
    Matt Makris
    ------------------------------