Discussions

Expand all | Collapse all

Pipelines - not recognizing Record ID#

  • 1.  Pipelines - not recognizing Record ID#

     
    Posted 17 days ago
    I have a pipeline that triggers when a record is edited. It pulls in the related record ID#, and then runs a search to match that related record ID# to a record ID#. For some reason, on that query, it changes the record id# from just a plain number to a number with decimal points. See screenshot. I am trying to find a formula that I can use to trigger this to round up, or find a way around this
    . Has anyone else come across this issue before?

    thanks, Urs

    ------------------------------
    Ursula
    ------------------------------


  • 2.  RE: Pipelines - not recognizing Record ID#

    Posted 17 days ago
    I believe I heard about this issue on a Webinar and they did some Jinja language trick.  I wonder if you made a text field formula for to mirror the record ID# field if it would then treat it as a character and get a clean hit that way.

    ie [Record ID# text] with a formula of ToText(Round([Record ID#]))

    ------------------------------
    Mark Shnier (YQC)
    Quick Base Solution Provider
    Your Quick Base Coach
    http://QuickBaseCoach.com
    mark.shnier@gmail.com
    ------------------------------



  • 3.  RE: Pipelines - not recognizing Record ID#

     
    Posted 17 days ago
    Thanks Mark! Funnily enough, that is what I ended up doing. I had to create text versions of all the related record ids I was referencing, and it seems to work. I will have to do some further testing to make sure it works in all instances, but this is a good workaround. I am surprised that this hasn't been identified as a bug of some kind, seems a little convoluted to get a record id.

    ------------------------------
    Ursula
    ------------------------------



  • 4.  RE: Pipelines - not recognizing Record ID#

    Posted 16 days ago
    Edited by Angel R 16 days ago
    Ursula, with jinja templates you'd want to use the 'round' filter. So instead of round({{ a.bill_to_matter }}), you just write {{ a.bill_to_matter|round }}

    ------------------------------
    AR
    ------------------------------



  • 5.  RE: Pipelines - not recognizing Record ID#

     
    Posted 16 days ago
    Thanks Angel, What I ended up using was the {{ a.bill_to_matter|int }} option instead. I didn't want to use Round because this is the Record ID# (key field) and I didn't want there to be any mistakes with it rounding up or down a number and it creating a record related to the wrong record.

    ------------------------------
    Ursula
    ------------------------------