Discussions

Expand all | Collapse all

Editable Report link not showing selected related field

  • 1.  Editable Report link not showing selected related field

    Posted 25 days ago
    I have an editable report link on my form. This form link has a proxy field on it Named SO# (or Assigned SOs in the pictures below).

    When I choose a SO from the dropdown, it looks good. But when I click off of it, it disappears. Typically this means the proxy field might not be matched to the filtered report I am using, but I checked and that isn't the case this time.

    For reference:
    Proxy Field is what is shown in the picture.
    Proxy Field is a text field Named SO#
    Filtered Report Used to select has only one field - SO#.

    I can't figure out why it is blank. Thoughts?

    See below: First I select a Service Order. When I click off of it, it flashes the record ID, then goes blank (it is actually there, just visibly blank)




    Once saved it will show up correctly.



    ------------------------------
    Mike Tamoush
    ------------------------------


  • 2.  RE: Editable Report link not showing selected related field

    Posted 25 days ago
    Is there a valid field in the Advanced Properties for the table for the first Record Picker field?

    ------------------------------
    Mark Shnier (YQC)
    Quick Base Solution Provider
    Your Quick Base Coach
    http://QuickBaseCoach.com
    mark.shnier@gmail.com
    ------------------------------



  • 3.  RE: Editable Report link not showing selected related field

    Posted 25 days ago
    Yes, but not a great field so I changed it. Still no luck. Perhaps this is a mission for customer support?

    ------------------------------
    Mike Tamoush
    ------------------------------



  • 4.  RE: Editable Report link not showing selected related field

    Posted 22 days ago
    Update:

    Working with Customer Support and we have not pinpointed the issue, but leaning towards it is a bug. One interesting thing: If I create a formula field that is a mirror of the proxy field, and add that as a column in the report, suddenly the behavior is exactly as expected.

    No idea why yet....I tried mirroring other fields, putting dummy text, etc, nothing worked. But for some reason, actually having a mirrored field seems to help??

    Also, I think it works with the related field, but not if using a proxy field.

    ------------------------------
    Mike Tamoush
    ------------------------------



  • 5.  RE: Editable Report link not showing selected related field

    Posted 19 days ago

    In the event someone stumbles on this post, according to customer support this is expected behavior in a cross app relationship.

    If needed, use the work around I provided by creating a mirrored field to the proxy field.

    For mine, I took it one step further. The proxy field simply needs to be included on the mirror field, other items can be there. So I made a rich text field, mirrored the proxy field but made it size 1 font, and white (so essentially hidden), then mirrored another useful field. Works out pretty nice. No clue why it works but, there it is.



    ------------------------------
    Mike Tamoush
    ------------------------------



  • 6.  RE: Editable Report link not showing selected related field

    Posted 19 days ago
    Thx Mike .. pretty obscure.  i guess this is a heads up for a potential strange behaviour when using a cross app  relationship in Grid Edit.

    ------------------------------
    Mark Shnier (YQC)
    Quick Base Solution Provider
    Your Quick Base Coach
    http://QuickBaseCoach.com
    mark.shnier@gmail.com
    ------------------------------