Discussions

Expand all | Collapse all

IOL not working in quickbase

  • 1.  IOL not working in quickbase

    Posted 08-23-2021 05:51
    Hi Everyone,

    I am facing issue in loading my custom javascript code page, since javascript is deprecated in quickbase i used code pages as an alternative to remove js from formula fields. Earlier formula field was like as shown in image (Save_Record.png) , I removed the onclick functionality from the formula field and added it to code page (Custom_js.png), third image(modified_save_Record.png) shows the modified  formula field after removing onclick. Then in order to load my custom code page I was using IOL ( making a formula field and writing  ""&[iol] & "button.js" & [/iol]&""  to load page) , but now its not working. This way I added these fields in the form and used to preview it , everything was working fine, but after 15/08/2021 , IOL is not working.

    So my question is how can load my code pages so that code page, formula field and forms are connected as before.

    ------------------------------
    Adis Kljajic
    ------------------------------


  • 2.  RE: IOL not working in quickbase

    Posted 08-25-2021 16:51
    That technique uses JS, so, no, it's not going to work. If you're just trying to call a code page, you do not need the IOL technique to do that. A number of examples of using JS in Code Pages can be found here: Code Pages Examples.

    ------------------------------
    Blake Harrison
    bharrison@datablender.io
    /
    ------------------------------