Discussions

Expand all | Collapse all

Weird characters on an Outlook Exchange Sync connection

  • 1.  Weird characters on an Outlook Exchange Sync connection

    Posted 09-26-2018 18:07
    I have a Sync table coming in from Outlook.  The body field has many weird characters in it.  I'm not sure if this forum will accept them, but many emails have a an 



    character in place of a carriage return  and there are other weird characters too.  Any ideas on why or how fix that?




  • 2.  RE: Weird characters on an Outlook Exchange Sync connection

    Silver
    Contributor
    Posted 09-26-2018 18:12
    Are they possibly formatting characters? Can you pass the content of the body to some ascii only sieve that will remove the formatting first?


  • 3.  RE: Weird characters on an Outlook Exchange Sync connection

    Posted 09-26-2018 18:35
    I suspect that there is no easy answer here.  The main extra characters seem to be that one character, and I suppose I could parse out the text based on that separator in a PART formula and list together Part 1, Part 2 etc and use a "\n" separator to format and retain the carriage return.


  • 4.  RE: Weird characters on an Outlook Exchange Sync connection

    Top
    Contributor
    Posted 09-26-2018 18:39
    Just write a gigantic native formula that substitutes all offending characters in the Unicode space with an empty string.




  • 5.  RE: Weird characters on an Outlook Exchange Sync connection

    Posted 11-13-2018 18:48
    I'm having the same issue.  Was a simple resolution found?


  • 6.  RE: Weird characters on an Outlook Exchange Sync connection

    Posted 07-19-2019 18:17
    I got around this by creating a formula text field with the search & replace function:

    SearchAndReplace([Body],"�","")