Discussions

Expand all | Collapse all

Trouble setting up table to table relationship

  • 1.  Trouble setting up table to table relationship

    Posted 11-19-2018 21:01
    I have a PO Header Table and a PO Detail table and I am trying to set up a relationship between the 2 where there are many detail records attached to one header record. The common link between the 2 tables is the PO Number field. I thought that if I used the PO Number field as my reference field, it would automatically link the current information in the 2 tables together, however all I get is a drop down field in the child record where I would have to manually select the correct parent record. What am I doing wrong?


  • 2.  RE: Trouble setting up table to table relationship

    Posted 11-19-2018 23:25
    Are you launching off the parent record when you are creating the detail lines or are you entering the PO# manually and entering child record starting off at the child record table?


  • 3.  RE: Trouble setting up table to table relationship

    Posted 01-23-2019 17:54
    The problem is that the 2 tables are created from 2 separate spreadsheets full of data that I uploaded into QuickBase creating thousands of records in each table. What I am trying to do sync up the two tables of info using the one piece of info common to both tables, the "PO Number" field. It almost seems like I need to set up the relationship before uploading the spreadsheets? So basically create the 2 tables, each with a "PO Number" field. Then create the relationship between the two tables using that field as the key field, then upload the spreadsheets letting them create the rest of the fields?


  • 4.  RE: Trouble setting up table to table relationship

    Posted 01-23-2019 18:01
    This part is quite correct;

    So basically create the 2 tables, each with a "PO Number" field. Then create the relationship between the two tables using that field as the key field, then upload the spreadsheets letting them create the rest of the fields?

    The Key field of the PO table should be set to be the PO#.  

    But the Key field of the PO Lines table will just be the usual [Record ID#] field.