Expand all | Collapse all

Connected Table refresh errors

  • 1.  Connected Table refresh errors

    Posted 10-24-2018 06:06
    I am not able to get quickbase to successfully fully sync with connected tables. The source csv files are UTF-8 and stored in a google drive. I have also tried dropbox and get the same errors with different csv's and different data

    - It only imports many less rows than are in the CSV file for example 1,000 rows (exactly) of 16,560 rows
    - another table imported only 15,000 of 185,000 rows

    The typical error on all these tables looks like this: "There was a problem refreshing the table.
    Elapsed time was 2 minutes. The file was CRM0003.csv. The error was: Could not parse XML input - XML Parsing Error. reference to invalid character number at line 90 column 3 (which is byte 18351)"

    but although I get this type of error on all tables it does not at all correspond to the number of rows imported.

    If anyone has experienced similar issues and overcome it I would be very interested to hear from them.

    Kind regards


  • 2.  RE: Connected Table refresh errors

    Posted 10-24-2018 06:17
    More than likely you have one of these five characters:

    & < > " '

    in your CSV that are not being substituted with character entities.

    I think this occurs because QuickBase is using API_ImportFromCSV with an XML payload.

  • 3.  RE: Connected Table refresh errors

    Posted 10-24-2018 07:02
    Hi Dan, thanks for your quick response. I do have some of those but it doesn't seem to correspond with the error. Will do a search and replace for each and see if I still get it.

  • 4.  RE: Connected Table refresh errors

    Posted 10-24-2018 09:45
    Your blob of CSV is probably being submitted through API_ImportFromCSV which has an XML body, Those five characters are invalid within XML unless they are replaced with character entities. If they are not replaced you will get an XML parsing error. I think the error message is consistent.

    Or there could be a character encoding issue. QuickBase does not use utf-8 - they use windows-1252. 

    check byte 18351.

  • 5.  RE: Connected Table refresh errors

    Posted 10-24-2018 10:13
    On second thought perhaps it isn't a character entity issue. If it was, everyone with a CSV file with one of those five characters might be having this problem (and they are not). In addition to using API_ImportFromCSV QuickBase may be wrapping the CSV data within a CDATA section which obviates the character encoding. Who knows what voodoo is going on.

    I now suspect it is a character encoding issue.

  • 6.  RE: Connected Table refresh errors

    Posted 10-26-2018 04:27
    After I removed all of the offending characters I still get the issue. Any other ideas?
    Did you say it should be encoded as a non UTF-8 file (windows or MS DOS)?