Discussions

Expand all | Collapse all

Copy this value when using Copy this [record]"" not available for Address fields?

  • 1.  Copy this value when using Copy this [record]"" not available for Address fields?

    Posted 08-09-2017 20:06
    The checkbox to "Copy this  value when using copy this [record]" is not present for Address fields. Anyone else experiencing this?


  • 2.  RE: Copy this value when using Copy this [record]"" not available for Address fields?

    Bronze
    Contributor
    Posted 08-11-2017 19:06
    Yeah, I don't see that option available when I look at my address fields, but it is there for other fields. Interesting, I'd never noticed that fact before. I wonder why they don't want that feature available to us for address fields. I could certainly make a business case for needing it.


  • 3.  RE: Copy this value when using Copy this [record]"" not available for Address fields?

     
    Posted 10-12-2017 18:56
    Wow, I just ran into this. My app's been copying addresses for a couple years. I can only guess that my recent visit to the address field to change something else, and it updated so that it can't auto-fill any more. This is really going to annoy my users, and run into problems, as record assignment is based on the address. Blah.


  • 4.  RE: Copy this value when using Copy this [record]"" not available for Address fields?



  • 5.  RE: Copy this value when using Copy this [record]"" not available for Address fields?

    Posted 10-12-2017 19:03
    Yup. It is extremely annoying because users are being required to re-enter the entire address every time they copy a record. It's annoying, time-consuming, and inefficient.


  • 6.  RE: Copy this value when using Copy this [record]"" not available for Address fields?

     
    Posted 10-12-2017 19:12
    Looks like I'll be making an API_addrecord button. That should fix it.


  • 7.  RE: Copy this value when using Copy this [record]"" not available for Address fields?

     
    Posted 10-12-2017 19:54
    Here's my URL field button formula, FWIW:

    URLRoot() & "db/" & [_DBID_QUOTE_REQUESTS] & "?a=API_GenAddRecordForm"&
    "&_fid_7="&URLEncode([Name])&
    "&_fid_8="&URLEncode([Company])&
    "&_fid_14="&URLEncode([Email])&
    "&_fid_85="&URLEncode([Address: Street 1])&
    "&_fid_86="&URLEncode([Address: Street 2])&
    "&_fid_87="&URLEncode([Address: City])&
    "&_fid_88="&URLEncode([Address: State/Region])&
    "&_fid_89="&URLEncode([Address: Postal Code])&
    "&_fid_90="&URLEncode([Address: Country])&
    "&_fid_45="&URLEncode([Terr override])&
    "&_fid_6="&URLEncode("Rep- Send Quote")&
    "&_fid_20="&URLEncode([Product family])


  • 8.  RE: Copy this value when using Copy this [record]"" not available for Address fields?

    Posted 01-17-2019 13:58
    According to quicbase support, there is a bug and they had to remove it.  Not sure when it will be added back.