Discussions

Expand all | Collapse all

Summary Field Count is Not Correct

  • 1.  Summary Field Count is Not Correct

    Posted 03-28-2018 02:39
    I created Summary Field on Parent Table to show count of Child Table records, this summary field shows 121. But there are only 120 Child table records when I go to the Child Table. When I look at embedded report of Child Table on Parent Table, shows 120. It's only when I use the Summary Field in a report, shows 121. This is happening for several records on Parent Table, but then in others it's just fine. Is this a bug?


  • 2.  RE: Summary Field Count is Not Correct

    Posted 03-28-2018 03:07
    The most likely cause is that the report you�re using on the form has a filter built into it.


  • 3.  RE: Summary Field Count is Not Correct

    Posted 04-25-2018 20:56
    Thanks. 


  • 4.  RE: Summary Field Count is Not Correct

    Top
    Contributor
    Posted 03-28-2018 14:19
    Hi Ruby,

    That is unusual to see that discrepancy between your report link and your summary field. As Mark noted one of the most common reasons that a report link and a summary field could show up with different results is if the report link contains a filter that is removing a record but the summary field does not. Alternatively it is possible to make a report link off a field that is not the key field for your Parent table. For example matching a text value of another field. In that case if the report link is set to a different field then the key field for a match that can cause some inconsistencies as well. 

    If after checking these two options you are still having issues figuring out what is going on I would suggest putting in a support case. Then a member of the Care Team can help you take a look at the discrepancy to help you isolate the source. I hope that information is helpful Ruby.  _


  • 5.  RE: Summary Field Count is Not Correct

    Posted 04-25-2018 20:56
    Thanks.