Discussions

Expand all | Collapse all

Help with a formula please

  • 1.  Help with a formula please

    Posted 10-18-2017 21:05

    Hello! I've been trying to figure this out for a good part of the day and am at the end of my rope. I could use some help please....

    Three fields:

    • Project ID

    • Project ID Video Asset

    • Project ID Child


    I would like the Project ID field to display the Project ID Child field. If Project ID Child is blank, I would like it to display Project ID Video Asset.


    These are the two formulas I've tried without luck:

    If ([Project ID Child] <> "", [Project ID Child],
    [Project ID Video Asset]<> "", [Project ID Video Asset])

    If ([Project ID Child]<> "", [Project ID Child], [Project ID Video Asset])


    I'm including a screen grab of the results that both of these formulas return.

    Please let me know if you need any additional info in order to assist.

    Thank you!!



  • 2.  RE: Help with a formula please

    Silver
    Contributor
    Posted 10-18-2017 22:13

    Hi

    Sounds like you want Project ID Child to be the 'proxy' of Project ID. Is this correct? As far as I know, you cannot create a 'co'-proxy field. I may be wrong, but I do not think you can.

    If the above is not the case, then it seems you want Project ID child to take precedence over project ID Video Asset (?)


    If(

    [Project ID Child]="",[Project ID Video Asset],[Project ID Child]

    )

    Is this what you're looking for?




  • 3.  RE: Help with a formula please

    Posted 10-18-2017 22:23
    Hi - I'm looking for the latter, but that formula returns the same result that I was getting with the other formulas.  
    Thanks for your response! 


  • 4.  RE: Help with a formula please

    Top
    Contributor
    Posted 10-19-2017 05:43
    Are any of the fields involved marked to be "unique"?


  • 5.  RE: Help with a formula please

    Top
    Contributor
    Posted 10-19-2017 05:47
    Oh i take that back.  Whatever formula you have in the "Formula Child" field is inserting a hyphen (-).  So it is never empty,  thus your next field is not what you'd expect.

    What is the formula for the child formula field? 

    Fix that and you should be good.


  • 6.  RE: Help with a formula please

    Posted 10-19-2017 12:16

    That's it!! Thank you so much! I changed that formula and it's working perfectly now.

    What a relief! Thanks again!!