Discussions

Expand all | Collapse all

Cannot access a report under a certain role/user

  • 1.  Cannot access a report under a certain role/user

    Posted 06-18-2019 18:47
    I have done all I know to do to allow a user/role to access reports.  However, there are still a couple of reports that are showing up with no data in them when accessed by this user.  Please advise.


  • 2.  RE: Cannot access a report under a certain role/user

    Bronze
    Contributor
    Posted 06-18-2019 20:23
    Does the user role in question have access to see the data that displays in that report? If they can access / view the report - but they don't see the data, either there is another permission setting restricting it, or you have a filter specific to their user that might be hiding those records as well. 

    Chayce Duncan | Director of Strategic Solutions
    (720) 739-1406 | chayceduncan@quandarycg.com
    Quandary Knowledge Base


  • 3.  RE: Cannot access a report under a certain role/user

    Posted 06-18-2019 20:26
    There is probably another permission setting that is restricting it...but, I cannot find it.  The filters are fine because the data is there when viewed by other users/roles.  I'll look at it again. thank you


  • 4.  RE: Cannot access a report under a certain role/user

    Bronze
    Contributor
    Posted 06-18-2019 20:28
    I would check the permissions to the table specifically to start. Another idea - tossing it out there - might be to see if there are field permissions or issues with one of the fields that you are using to filter. For example - if you are filtering on something like an 'Admin Status' field in the report - but a regular user has no access to that particular field, then the report might have some odd behavior

    Chayce Duncan | Director of Strategic Solutions
    (720) 739-1406 | chayceduncan@quandarycg.com
    Quandary Knowledge Base


  • 5.  RE: Cannot access a report under a certain role/user

    Posted 06-19-2019 15:08
    I made a new table and forgot to go in and set the access to the table. I tested after setting the table up and reports in other tables that were connected. While going through fields and permissions then clicked on table access  and it finally occurred to me that I forgot to go there first.