"Test this app as another role" not showing up after QB update

  • 2
  • 3
  • Question
  • Updated 7 months ago
  • Answered
Since Quickbase applied their March update and added an option to test apps as a User, the entire "test this app as" option has disappeared for non admin roles.
"Test as another role or user" is not hidden for these roles. Is there another setting to configure? I read through the release notes and test role setting articles but don't see anything mentioned about this issue.
Photo of Zaya

Zaya

  • 92 Points 75 badge 2x thumb

Posted 2 years ago

  • 2
  • 3
Photo of Matthew Neil

Matthew Neil

  • 31,438 Points 20k badge 2x thumb
I'm having the same issue.  I'm curious if they even testes that out during the development
Photo of Zaya

Zaya

  • 92 Points 75 badge 2x thumb
So I reached out to Quickbase support and they're telling me I need to select "Edit app structure and permissions" in order to get that option which is not what I want to do. There's a reason why those users are not under Admin role. Still exploring alternative options. If someone finds a solution, please let me know. 

Photo of Matthew Neil

Matthew Neil

  • 31,438 Points 20k badge 2x thumb
That defeats the purpose of the "Test as another role or user" checkbox.

#QuickBaseSupport #Fail

Photo of Zaya

Zaya

  • 92 Points 75 badge 2x thumb
Yep, that's exactly what I told them. And the support person agreed with me but he said it's the only option for right now. 
Photo of David

David

  • 60 Points
I too have the same problem. We have key people here that both train and support applications where this ability to change roles is a real advantage.

Our data is driven by roles, home pages and reports within each. Each role sees what they need to see and be responsible for. They just took away a major function for these key people. These key people need their own roles for their jobs as well so that records, reports, and work can flow to them in their job functions. I don't want to make everyone an administrator but I want certain people to have the ability to help train and manage others using the ability to put themselves in another role.

This is going to cause major issues for us. 
Photo of Alicia

Alicia, Employee

  • 210 Points 100 badge 2x thumb

We heard your feedback that test as a specific role should be available to users with Basic, Sharing permissions, too. We’ll be updating QuickBase in the next day or two so that test as a role will again be available to app managers and users in a role with Admin; Admin, Sharing; and Basic, Sharing permissions. Test as a specific user will remain available to app admins only (Admin permissions).

Photo of Gaurav Sharma

Gaurav Sharma

  • 5,576 Points 5k badge 2x thumb
Thank you Alicia for your update. :)
Photo of David

David

  • 60 Points
Thanks Alicia! It's good to know someone is listening to us.
Photo of Alicia

Alicia, Employee

  • 210 Points 100 badge 2x thumb

QuickBase is updated and test as a role is now available to app managers and users in a role with Admin; Admin, Sharing; and Basic, Sharing permissions. Thanks for letting us know this is important. And please keep the feedback coming – we’re listening.

Photo of Kelly

Kelly

  • 1,692 Points 1k badge 2x thumb
This is selected on my app, and I'm not able to see it. I can only test as other user roles in my main app. It doesn't make sense.
Photo of QuickBaseCoach App Dev./Training

QuickBaseCoach App Dev./Training, Champion

  • 46,496 Points 20k badge 2x thumb
If you are an admin of an app, you should be able to test as role if that test as role box on the Hide UI settings in Role User Interface is not checked.
Photo of Kelly

Kelly

  • 1,692 Points 1k badge 2x thumb
The option is not there. My account information is not even available unless I'm in the main app. I think it's a bug. I have a support case.
Photo of QuickBaseCoach App Dev./Training

QuickBaseCoach App Dev./Training, Champion

  • 46,496 Points 20k badge 2x thumb
Ok, I'm sure that Support will get you sorted out.
Photo of Kelly

Kelly

  • 1,692 Points 1k badge 2x thumb
Got it! Had to go to Settings -> Branding -> Under Header Tab -> Uncheck Hide Quick Base standard menu options
Photo of Devin

Devin

  • 362 Points 250 badge 2x thumb

I was able to test in another role/user. Now the issue arises that when I test as a user with access to only one application (Parent Table, Application 1), and then click on a related record (via Report Link to Child Table, Application 2) in another application, it takes me to the restricted application as the Administrator. I can't select test as user there because this test user is not a user of the restricted, second application.

Any ideas on a solution or did I just land on a quirk? It makes 'test as user' superfluous in this instance if it's a quirk.

(Edited)