attachments not visible in edit mode when dynamic form hide conditions in place

  • 0
  • 1
  • Question
  • Updated 4 years ago
  • Answered

Our data comes into quickbase from an outside tool. I have an attachment field (we'll call it "PHOTO") and I have set the dynamic rules to hide the field PHOTO if no image is taken. This is working properly in view mode, but not in edit mode. In edit mode, quickbase always treats the field as if it were blank. The same form is used for edit and view mode, so why is quickbase displaying the fields differently?


My form rule:

when PHOTO is equal to (blank) hide PHOTO

Photo of Taylor

Taylor

  • 52 Points

Posted 4 years ago

  • 0
  • 1
Photo of QuickBasePros (Laura Thacker)

QuickBasePros (Laura Thacker), Champion

  • 5,456 Points 5k badge 2x thumb
Is the field hidden in Edit mode?  If so; check that you have set the Field in the Form Layout to display on Edit and View
Photo of Taylor

Taylor

  • 52 Points
No, it is not hidden. It is set to display in add, edit and view.
Photo of QuickBasePros (Laura Thacker)

QuickBasePros (Laura Thacker), Champion

  • 5,456 Points 5k badge 2x thumb
I would be happy to help you offline to see if we can solve this; or identify a bug.  Click on my profile to get my contact info.
Photo of Taylor

Taylor

  • 52 Points
Follow up: This looks to be a bug. Attachments are not recognized as being present vs. absent when in edit mode.
Can you try this?

Make a formula checkbox field called [File is loaded?] like this

ToText([File Attachment #1])<>""

and base your form Rule on [File is loaded?]
Photo of Taylor

Taylor

  • 52 Points
Yes, this is the workaround we ended up using. Thanks to both of you for your feedback!