Automations keeps timing out

  • 0
  • 1
  • Question
  • Updated 5 months ago
  • Answered
I've set up an Automation that seems to work just fine with a single record activation on the trigger, but if I enter multiple records that should trigger the Automation, it times out with an error message. Is the time limit based on each record that triggers it, or as a total action?

If the latter, how is that going to be effective for eliminating redundant actions?
Photo of Jennifer Peterson

Jennifer Peterson

  • 296 Points 250 badge 2x thumb

Posted 5 months ago

  • 0
  • 1
Photo of Evan Martinez

Evan Martinez, Community Manager

  • 8,774 Points 5k badge 2x thumb
Hi Jennifer,

I am sorry to hear you are having issues with an Automation. What type of Automation are you running for your set up? How many steps does it have built into it and what roughly is it set up to do? What is the specific error message you are seeing? 
Photo of Jennifer Peterson

Jennifer Peterson

  • 296 Points 250 badge 2x thumb
It's setup that when a Report record is created, it will create the Task child records (13 or 15 actions, depending on the type of Report) each Report needs. The time out is occurring when I upload 35 Report records, which is only going to get worse when I have to upload 183 Report records.
Photo of Gil Spigelman

Gil Spigelman

  • 870 Points 500 badge 2x thumb
Evan, I'm having the same issue, but doing a table to table import via an automation. It's pulling in almost 300 records during each import. I put in a support case for it.
Photo of Evan Martinez

Evan Martinez, Community Manager

  • 8,774 Points 5k badge 2x thumb
Hi Jennifer,

I would suggest in this instance doing the same thing that Gil did and putting in a support case to have a rep look at it with you. It sounds like your Automation might be running into a limit and this way we can just log which one and check in with out Automation team for their feedback after looking at your specific errors and use case.