COLOR A CELL IN REPORT?

  • 0
  • 1
  • Question
  • Updated 4 years ago
  • Answered
Please advise:

Please check the syntax of your entire formula. Possible culprits are a mismatched set of parentheses, missing quotes, or an extra bracket.


Case([FRONT DOOR COLOR (EXCEPTION)],  
“SW7510 CHATEAU BROWN”,“<div style=\”background-color:Green;\”> Green</div>”,
“SW7041 VAN DYKE BROWN”,”<div style=\”background-color:Yellow;\”> Yellow</div>”,
“SW7515 HOMESTEAD BROWN”,“<div style=\”background-color:Red;\”> Red</div>”,"")
Photo of Lynne8817

Lynne8817

  • 630 Points 500 badge 2x thumb

Posted 4 years ago

  • 0
  • 1
Photo of Lynne8817

Lynne8817

  • 630 Points 500 badge 2x thumb
This is copied from my formula field:Case([FRONT DOOR COLOR (EXCEPTION)],
“SW7510 CHATEAU BROWN”,“<div style=\”background-color:Green;\”> Green</div>”,
“SW7041 VAN DYKE BROWN”,”<div style=\”background-color:Yellow;\”> Yellow</div>”,
“SW7515 HOMESTEAD BROWN”,“<div style=\”background-color:Red;\”> Red</div>”,"")
Can you double check that your quotes are the " quotes near the enter key and not the curly 66 99 quotes?   What you posted look curly to me.  QuickBase chokes on curly quotes which tend to come from Word. The only straight quotes I  see are the final "" in the else condition.
Photo of Lynne8817

Lynne8817

  • 630 Points 500 badge 2x thumb
I guess when I copied the formula from http://quickbase.intuit.com/blog/2009/02/02/quick-and-dirty-cell-colorization-in-quickbase/, curly quotes had been used.  I replaced them with the correct quotes and so far, so good.  Thx
Ya, greater minds than ours would know under what conditions the " get changes to the curly quotes during copying and pasting.  But once bitten, twice shy.  I got bit.
Photo of Lynne8817

Lynne8817

  • 630 Points 500 badge 2x thumb
Yep!  Ok...another issue now.  Colors are showing on screen, but not on printed report? Any thoughts on that?
Right, so that is a Browser setting.  On each PC that is gong to use the app, you will need to enable background shading.  For example in Firefox and also IE it's under File, then Page Setup and there is a checkbox.

I did not test Chrome but it looks like File Print, and then options.