Constant loading when searching a table

  • 0
  • 1
  • Question
  • Updated 9 months ago
  • In Progress
Hi, I am hoping there is something I can do to solve this but it seems that when I perform a search in my largest tables the data is continuously "Loading...." and it never seems to find anything. I can refresh the database and then it seems to find what I am looking for. This is VERY annoying and the only thing I can think is that my database is "too large" for effective searching. Hoping someone has an idea to make this stop!


Photo of Jeff Helseth

Jeff Helseth

  • 100 Points 100 badge 2x thumb
  • annoyed

Posted 9 months ago

  • 0
  • 1
Photo of QuickBaseCoach App Dev./Training

QuickBaseCoach App Dev./Training, Champion

  • 51,456 Points 50k badge 2x thumb
Can you tell us how many records are in the report and how many columns on the report.  Note that if you have hundreds of thousands of records, Quick Base needs to do that work to search all searchable fields on the report.  Are there columns which are not necessary on that report? 
(Edited)
Photo of Jeff Helseth

Jeff Helseth

  • 100 Points 100 badge 2x thumb
So, I have a little under 16,000 records. The report has 20 columns, which all are necessary. I seem to be having this problem more recently.

Sometime I'll type in several searches consecutively and they return the appropriate results almost instantly. Then randomly I will search a phrase and then it will just sit on "Loading..." like I included in the original post.

I don't suspect that it is the size of my database but perhaps something to do with a faulty internet connection?

Anything helps, so thanks you for your time!
Photo of QuickBaseCoach App Dev./Training

QuickBaseCoach App Dev./Training, Champion

  • 51,456 Points 50k badge 2x thumb
The issue is unlikely to be related to your table size as 16,000 records by 20 columns is that really a lot.

I do know though that when you run a report and then leave it sit for a long time, then Quick Base sort of forgets what is on that report and cannot quickly search it.  How long is long,  Hmmm, maybe like 5-10 minutes or so?  But usually it gives a more meaningful error message to ask you to re-run the report.

But it sounds like buggy behaviour that will need Quick Base support will need to look at.  I suggest that you put in a Support Case by using the HELP "?" at the top right of all pages..