'Cross-application relationship' cannot find the application 'Select an app'

  • 0
  • 1
  • Question
  • Updated 6 months ago
  • Answered
  • (Edited)
I feel a bit stupid but I can't make a 'Cross-application relationship' as my target application is not listed.

I have two applications
1) 'Global Locations' with a table 'Countries'
2) 'Global suppliers' with a table  'Companies'
(Companies : Countries = one : many)

When I go to 'Global Locations' >> Settings > App properties there is a list with applications and a blue button 'Select an app'. BUT.....my app 'Global Suppliers' is not listed.
When I click the button, the button dissapears and that's it.
What is going wrong here.

PS:I also tried it the other way around; create a relationship from 'Companies' to 'Countries' than the message appears that I need to make a crossreference and as I'm an admin it gives me to option to go to the 'Application Properties for Global locations'. And from there the same as above

I did this before and it worked before :-)

Please tell me what am I doing wrong?????
Photo of Jan-Willem

Jan-Willem

  • 490 Points 250 badge 2x thumb

Posted 6 months ago

  • 0
  • 1
Photo of QuickBaseCoach App Dev./Training

QuickBaseCoach App Dev./Training, Champion

  • 51,456 Points 50k badge 2x thumb
This will work, at least it always works for me.  You need to go to Parent Table's  Application Settings / App Properties at the bottom of the page to allow the child to make a relationship.

But then you actually build the relationship only from the child side. 
Photo of Jan-Willem

Jan-Willem

  • 490 Points 250 badge 2x thumb
I simply don't see te child table in there and I can't either search for it.
I'm an administrator of the Parent table,  though not the Owner/Managerof the parent table. Could that perhaps be the case?
(Edited)
Photo of QuickBaseCoach App Dev./Training

QuickBaseCoach App Dev./Training, Champion

  • 51,456 Points 50k badge 2x thumb
I’m not sure what to suggest. You may need to go to Support.
Photo of Jan-Willem

Jan-Willem

  • 490 Points 250 badge 2x thumb
SOLVEDIt's a browser thing. Firefox and Chrome --> NO . M$ IE --> YES
Photo of QuickBaseCoach App Dev./Training

QuickBaseCoach App Dev./Training, Champion

  • 51,456 Points 50k badge 2x thumb
It was probably caused by a pop up blocker then.

I suggest trying IE again and looking for an indication of a pop up being blocked.