Dynamic Form Rules only working on Edit Form but not on View Form

  • 0
  • 1
  • Question
  • Updated 3 years ago
  • Answered
The rules to hide fields (that are located on the form) work properly but only when you are in Edit mode. When you hit save or even open a new record these fields (which are lookup fields from a parent table) are still showing. I've never seen this before, any ideas?
Photo of Leanne

Leanne

  • 262 Points 250 badge 2x thumb

Posted 4 years ago

  • 0
  • 1
Photo of Leanne

Leanne

  • 262 Points 250 badge 2x thumb
To update, it is not a problem in the Add New Form, only in the View form are the rules not working.
Photo of QuickBaseCoach App Dev./Training

QuickBaseCoach App Dev./Training, Champion

  • 60,058 Points 50k badge 2x thumb
Maybe your show hide rules are working on the proxy fields from the lookups and not the actual [Related Parent]. Or vice versa.
Photo of Leanne

Leanne

  • 262 Points 250 badge 2x thumb
Thanks for the response but I do not have proxy fields set up. These are new fields on the parent table being pulled in as numeric lookup fields.The rules work find on add new or edit form but not on the view form (which looks sloppy when viewing a bunch of empty fields). Any other ideas?
Photo of QuickBaseCoach App Dev./Training

QuickBaseCoach App Dev./Training, Champion

  • 60,058 Points 50k badge 2x thumb
Can you give me one example of a Rule which is not working?  Also, can you confirm that you have not pink warnings on your form rules?
Photo of Leanne

Leanne

  • 262 Points 250 badge 2x thumb
There are no pink warnings. The rules all look like this:

When [budget line 2] is equal to 0, hide [budget line 2] and hide [another field]

I've also tried variations, like "when [budget line 2] is < 1", and the opposite "when [budget line 2] is > 0, then show [budget line 2]"
There are 5 budget lines that can be entered but most of the time it will only be 3 of them filled in. I want all the budget lines that do not have a money amount listed in the parent table to not have a visible field on the child table.
Photo of QuickBaseCoach App Dev./Training

QuickBaseCoach App Dev./Training, Champion

  • 60,058 Points 50k badge 2x thumb
have you tried
when budget line 2 equals (blank), then hide budget line 2?  ie just compare to an empty field?
Photo of Leanne

Leanne

  • 262 Points 250 badge 2x thumb
Well that did the trick!! Thanks so much for the help!!
Photo of QuickBaseCoach App Dev./Training

QuickBaseCoach App Dev./Training, Champion

  • 60,058 Points 50k badge 2x thumb
:)
Photo of Ben L

Ben L

  • 100 Points 100 badge 2x thumb
I don't think this answers the question of why the form rules work in edit but not view. I'm having the same issue, where my form rules aren't working when in view mode, but do in edit. I'm hiding sections when a related service = 24.
Photo of Matthew

Matthew

  • 0 Points
I had the same issue, where my form rule changes [field] to value [text] when [other field] equals [option1]. The [text] appears in the edit form, but it is blank when you are just viewing or looking at it from the table.
Photo of QuickBaseCoach App Dev./Training

QuickBaseCoach App Dev./Training, Champion

  • 60,058 Points 50k badge 2x thumb
Form Rules which edit a record  only work when the form is being edited.  They do not work just with the passage of time or when a summary or lookup field changes.  You will need to use a formula to do that.
Photo of Jeremy

Jeremy

  • 0 Points
I have the same issue. A rule 'If a date is before the current date, hide a field' works in edit mode, but not in display mode.
Photo of Lily

Lily

  • 0 Points
i have the same issue... fields in a rule (though they are shown to be on the form as well) only show on edit , not on the view.  How do you write a formula for this situation?
Photo of QuickBaseCoach App Dev./Training

QuickBaseCoach App Dev./Training, Champion

  • 60,058 Points 50k badge 2x thumb
Lily, you are usually better off posting a new question than to tack onto an old thread.  But I happened to see this.  If oyu have a field that is showing in edit but not in view modes, then you have probably set the form properties for that field to just show in edit mode.  or else, you in fact have more than one form in use and are using one form for View and another form for edit.  Do you see multiple forms in the Settings for that Table.
Photo of Lily

Lily

  • 0 Points
Only one form is attached and the fields that are having the issue are all set up as edit,view,add status.  They are appearing when adding a record in, and in the edit mode , but when view is selected they are not showing there.
Photo of QuickBaseCoach App Dev./Training

QuickBaseCoach App Dev./Training, Champion

  • 60,058 Points 50k badge 2x thumb
I have never heard of that happening.  If you like you can contact me via the information in my profile and i will have a very quick look at it with you.
Photo of David

David

  • 10 Points
What was done to fix this problem?  I am seeing the same issue.
Photo of David

David

  • 10 Points
What was done to resolve this, I am seeing the same issue.
Photo of Leanne

Leanne

  • 262 Points 250 badge 2x thumb
Hi David, I think it was as simply as the rule should have been checking if <blank> instead of checking if "0" . Sometimes this happens when a field does not have the option box "Treat blank values as "0" in calculations" checked off. Hope this info helps!
Photo of David

David

  • 10 Points
Thanks Leanne,  My issue is the rule is based off a text drop down.. if status is one of the first 4 selections, hide these sections in the form, if the other selections, hide a different set of sections.

I had it set up as greater than/equal to, which works fine in edit mode but my assumption is it reverts to alphabetical order when in view mode... trying to figure out how to add multiple "any" conditions to the rule.
Photo of David

David

  • 10 Points
and I think I just answered my own question...

yup, got it.
Photo of Leanne

Leanne

  • 262 Points 250 badge 2x thumb
:) yep, do the multiple conditions rule-type.
Photo of David

David

  • 10 Points
thanks for responding, i think im starting to get the hang of this.