European users having problems "saving as a spreadsheet"

  • 0
  • 2
  • Question
  • Updated 10 months ago
  • Answered
Our users in the USA are able to use the "save as a spreadsheet" functionality without any issues.  However, when our users in Europe save as a spreadsheet, all of the data is in one column.  They have tried using text to column to separate the data but it does not work properly.  Our users have tried to open in Excel right from the browser and have saved it to their computer before opening.  Neither option works.

Has anyone else experienced this issue?
Photo of Meghan

Meghan

  • 94 Points 75 badge 2x thumb

Posted 1 year ago

  • 0
  • 2
Photo of Matthew Neil

Matthew Neil

  • 31,438 Points 20k badge 2x thumb
I'd open a support case for this.

But, I have noticed that depending on the 'workload' of an application the csv export can have some errors in the data.
Photo of QuickBaseCoach App Dev./Training

QuickBaseCoach App Dev./Training, Champion

  • 51,166 Points 50k badge 2x thumb
It could be differences in the default settings for excel as to what the recongnized delimiters are for opening CSV files, but I'm not sure where those settings are in Excel.
Photo of Esther

Esther

  • 702 Points 500 badge 2x thumb
Do you have any update in this case.
This issue is killing me.

My users complain about the can not  convert the data in excels sheets.

Our PCs are set up with EU system, where the decimals are separated by ",",

I know that if I change the computer set up from decimals as "," to decimals "." ( this is the USA system) it works fine with QB, but them my users have issues with the others programs.

Any help?
Photo of Meghan

Meghan

  • 94 Points 75 badge 2x thumb

I opened a support case and this is what QB sent me.  My users in Europe followed the instructions and can now save as a spreadsheet successfully.


"I did some digging and it appears this is an issue with csv files and how they are handled in Excel based on the region settings. If the computer is set to a region which does not use the comma as the list separator, a csv file using commas as the separator will not open properly. Below is a link to a Microsoft help article discussing how to import a .csv file into Excel and at the bottom it walks through the steps to change the separator for .csv files. I have also included another link to a Excel User forum post which discusses this issue.

https://support.office.com/en-ie/article/Import-or-export-text-txt-or-csv-files-5250ac4c-663c-47ce-937b-339e391393ba

https://superuser.com/questions/407082/easiest-way-to-open-csv-with-commas-in-excel"

Photo of QuickBaseCoach App Dev./Training

QuickBaseCoach App Dev./Training, Champion

  • 49,562 Points 20k badge 2x thumb
Thx for taking the time to post the Support response.
Photo of Esther

Esther

  • 702 Points 500 badge 2x thumb
Thank you Megan for your help, I have been reading it.

After the research I am stuck, I do not see the way to let my users to work with coma as decimals and we can not change the set up of all computers because they need to use the EU set up for most of the programs.

let me explain it:


One example; with this report in QB where some fields are set up as come in decimals and other with dots , this way we can see the outcome of the two cases with one report.



If the PC is set up as EU ( comas in decimals) the outcome is that al the data comes in one column all together

,



This column may be divided in more columns using the wizard (but it not always work fine), it means and extra work (the users do not like it), besides ones you get you data divided in more columns,  the numbers that in QB have coma as separator in decimals, now are text ( as you can see the spreadsheet placed quotations marks in the data with coma) so the users need to convert them again to numbers.




If your pc is set up as USA where the decimals are dot 


The outcome is that Excel divides the columns but convert the data-number with coma in data-text therefore the user need to pay attention to which fields need to be converted and which not.

I am pretty sure I can not be the first user in EU so it should be a simple way that does not require wizard conversions but I am not able to get it by myself.


Did any other user in EU find out the solution?