Exact Form Print URL Button Displaying Blank Page

  • 0
  • 1
  • Question
  • Updated 1 year ago
  • Answered
I have read similar posts where the solution was due to application tokens turned on, however mine is turned off and I am still showing a blank page. 

When I put a button to the exact form page, without an associated Record ID, on a dashboard page, the blank template will pull up. However, the URL button I have on my form that is supposed to open the exact form with all fields populated from the associated record suddenly stopped working. 

Any ideas?
Photo of Kalyn Peters

Kalyn Peters

  • 82 Points 75 badge 2x thumb

Posted 1 year ago

  • 0
  • 1
Photo of Keith

Keith, Champion

  • 1,148 Points 1k badge 2x thumb
Putting an exact form link on the dashboard should work.
If you put the link to the exact form page on your dashboard you need to include some parameter to let exact forms know which record(s) to process.

To process multiple records use a qid=x where x is the report id that filters the records to be processed in the table upon which the exact form was designed.

You have to pass in either rid=x or qid=x, you cannot omit these parameters so use one or the other.

you will see a blank page if the rid you passed in doesn't exist in the table.  So if you pass in rid=1 but there is no record in the table with the record id# field = 1 you will get a blank page, same holds true for passing in a qid value that doesn't exist.  qid=99 will render a blank page if there is no report with the id of 99

Keith