Frequently fails, but works some of the time: Gmail table: problem with automatic refresh

  • 0
  • 1
  • Question
  • Updated 1 year ago
  • Answered
I have a gmail account set to sync once an hour. I will get QB Notify emails 1-3 times a day warming the sync failed. The rest of the day I get "The table refreshed successfully in 2 minutes.
 ":

Notify Gmail table: problem with automatic refresh
There was a problem refreshing the Notify Gmail table, connected to Gmail, in the Sales Tracking app. The reason was:
[AUTHENTICATIONFAILED] Invalid credentials (Failure)
For information about resolving this problem, see Troubleshooting connected table refresh errors
I call my account 'notify' too, how Quickbase-y :)

Of course that means it works half the time, and going to the connection, the test tool works. I'd blame the size of my email account or my content filter, but it is failing on credentials. We send out emails via SMTP on this account, there is no persistent connection. 

I don't see any other complaints in the forms, so I suspect i'm a special case. Any ideas?
Photo of David

David

  • 680 Points 500 badge 2x thumb

Posted 1 year ago

  • 0
  • 1
Photo of QuickBaseCoach App Dev./Training

QuickBaseCoach App Dev./Training, Champion

  • 52,928 Points 50k badge 2x thumb
I have no idea why and suggest that you put in a support ticket to see if Quick Base support can help you as they have access to diagnostic tools.  You have probably done that already.

I recall that there is a new way to authenticate Sync setups now to use user tokens.  A thought is to change the Sync Connection to authenticate the new (and recommended) way to see if that makes a difference.
Photo of David

David

  • 680 Points 500 badge 2x thumb
Thanks. Yes, I will do that.

Crazy how it works sometimes, but I can see if the (internal I can't see it) API request to Google should be updated there might be problems. Reset the account connection again to see if that works, but hasn't in the past.
Photo of William

William

  • 142 Points 100 badge 2x thumb
I had similar problems with the G-Mail sync. After talking to Quick Base support they said it may have been because of some of the G-Mail labs I had subscribed to.
Photo of David

David

  • 680 Points 500 badge 2x thumb
Contacted support, and they say it is a known bug. Will carry on.
Issue ID: QBE011327: Scheduled refresh for Gmail connected table sometimes fails with "invalid credentials" error even though the connection still works

This conversation is no longer open for comments or replies.