Full report not working for non admin users?

  • 0
  • 1
  • Question
  • Updated 9 months ago
  • Answered
Anyone else having an issue where a blank page loads if the user isnt admin and tries to load a full report calendar?
Photo of Luke McInnes

Luke McInnes

  • 158 Points 100 badge 2x thumb

Posted 9 months ago

  • 0
  • 1
Photo of Thomas Slater

Thomas Slater

  • 130 Points 100 badge 2x thumb
Hi Luke!

Yeah I'm having the same issue - even checked that the users were able to access the specific reports in roles settings.


This is what it looks like:
Photo of QuickBaseCoach App Dev./Training

QuickBaseCoach App Dev./Training, Champion

  • 49,512 Points 20k badge 2x thumb
They often have software engineers on stand by after a new release, so I would put in a support ticket asap.
Photo of Luke McInnes

Luke McInnes

  • 158 Points 100 badge 2x thumb
I have, just no response as yet, was wondering if others had same issue while i wait for them to respond :)
Photo of Evan Martinez

Evan Martinez, Community Manager

  • 8,814 Points 5k badge 2x thumb
Hi Luke and Thomas,

If you are still experiencing the issue Mark is right, we would highly recommend putting in a Support Case. We would recommend the same to anyone else who is having issues with displaying and viewing their full report calendars. One thing you will want to note is that the new calendar reports are not compatible with our old dashboards as was contained in the release notes. The old dashboards are incompatible with the new calendar format so any dashboards that contain them just have to be rebuilt with the new dashboards or the calendar report needs to be removed.
(Edited)
Photo of gmcroberts

gmcroberts

  • 170 Points 100 badge 2x thumb
I am seeing the same behavior and tried to troubleshoot myself and found that its happening when the user is in a role that has the table that contains the calendar report hidden, if you unhide the table the calendar will display correctly.   Not ideal but a temporary workaround until it's fixed.
Photo of QuickBaseCoach App Dev./Training

QuickBaseCoach App Dev./Training, Champion

  • 51,036 Points 50k badge 2x thumb
It would be good to report that to Support as a clue for them.
Photo of gmcroberts

gmcroberts

  • 170 Points 100 badge 2x thumb
its already reported :)
Photo of Luke McInnes

Luke McInnes

  • 158 Points 100 badge 2x thumb
Thanks! I'll put this info on the ticket! We couldn't isolate the issue so created a code page to display the report frame and inserted that instead as a workaround.  Seems that it will display if you do it like that..... This also shows all the cal events in day/week mode, which doesn't seem to work properly if you put the report on a page.
(Edited)
Photo of gmcroberts

gmcroberts

  • 170 Points 100 badge 2x thumb
adding &ifv=1 to the end of the report URL will display it correctly too, less all the normal Quick Base headers etc. the url would look something like this https://quickbase.com/db/xxxxxxxxx?a=q&qid=5&ifv=1
(Edited)
Photo of Luke McInnes

Luke McInnes

  • 158 Points 100 badge 2x thumb
Works well! Thanks :)