Getting error code 2 for api_addrecord.

  • 0
  • 1
  • Question
  • Updated 4 years ago
  • Answered

Below is the response from quickbase

<?xml version="1.0"?><qdbapi><action>API_AddRecord</action><errcode>2</errcode><errtext>Invalid input</errtext></qdbapi>


When I checked for all the possible reasons for this error code (http://www.quickbase.com/api-guide/errorcodes.html) nothing really holds good in our case and also we have same application to test in our pre prod site and its working well.

Photo of Ganesh R V

Ganesh R V

  • 0 Points

Posted 4 years ago

  • 0
  • 1
Photo of Ⲇanom the ultimate (Dan Diebolt)

Ⲇanom the ultimate (Dan Diebolt), Champion

  • 29,964 Points 20k badge 2x thumb
What is the code that created the request? Nobody can debug this without seeing what the inputs are.
Photo of Ganesh R V

Ganesh R V

  • 0 Points
Below is the input:
<qdbapi><ticket>8_bj84w5tgb_byi7vx_k_a_bhnkc7vdaq4w8ecnmf7h9d7ukvzfd4stvuwbpdv3zkb3zkwp4bihyypt</ticket><field name="Rating">10</field><field name="Rating2">10</field><field name="Comments">from intuit.</field><field name="Customer_Name">nitin mehra</field><field name="Customer_Address">jos manor, ' bangalore, CT 06902</field><field name="Order_Number">00000000000000000045229556</field><field name="Customer_Type">Returning</field><field name="Products_Purchaced">Self Seal Standard/Voucher Check Envelopes,Secure Plus Voucher Checks,Self Seal Standard/Voucher Check Envelopes</field><field name="Version">Harmonized</field></qdbapi>