Having a problem with the Dynamic Form Rules

  • 0
  • 1
  • Question
  • Updated 2 years ago
  • In Progress
I am having a problem with Dynamic Form Rules not "sticking". In a connected table (child) there is a field for "commodity" (from parent table) that when selected will show the price (in a snapshot field of a reference field) for that specific commodity.  

There is one commodity that the price changes day to day so I added a field for manual input. I set up a form rule to state that when this commodity was selected to "hide" the snapshot field and "show" the manual input field.

In edit mode it works...the snapshot field is hidden and the manual input is shown. As soon as the record is saved it changes back showing the snapshot field and hiding the manual input field. 

I have never had a problem with dynamic form rules before.  Is there something I am missing or doing wrong?
Photo of Jeannette Bagnoli

Jeannette Bagnoli

  • 90 Points 75 badge 2x thumb

Posted 2 years ago

  • 0
  • 1
Photo of Chris

Chris, Champion

  • 4,390 Points 4k badge 2x thumb
In the right pane of the form attributes settings, have you checked off any fields as "add/edit" or "add/view" only?
Photo of Jeannette Bagnoli

Jeannette Bagnoli

  • 90 Points 75 badge 2x thumb
No, they are on "edit, add or view"
Photo of Chris

Chris, Champion

  • 4,390 Points 4k badge 2x thumb

May we see a screen shot of the form rule in question? Also, can you try changing the form rule to "Related Commodity" rather than "Commodity" if you're not already doing that?

Photo of Jeannette Bagnoli

Jeannette Bagnoli

  • 90 Points 75 badge 2x thumb
Here is a screen shot of what it is currently.  In the example above Commodity = "Price-Fumigant" and Price = "Fumigant Cost per Unit" (snapshot field) and "Fumigant Cost per Unit (input)" (manual input field)
Photo of Chris

Chris, Champion

  • 4,390 Points 4k badge 2x thumb

Let's start a process of elimination. First, try removing the "display a message" action and then see if that helps.