In one table only, Grid Edit does not allow editing

  • 0
  • 1
  • Question
  • Updated 9 months ago
  • Answered
I have a table in my app that will not let me edit records in a grid edit report. All reports from the table act the same way: the usual grid edit look is displayed, but clicking on a field does not allow editing, and clicking on save, apply changes, more..., or other buttons does not do anything.

I am able to click the Eye icon to view the record in a ford, and the Pencil icon to edit the record in a form (and I _am_ able to edit records in the form). It is frustrating, and the behavior only occurs in reports from a specific table.

The table is populated with child records from a single parent table. It has only the one relationship to its parent. 

Any ideas as to what I am missing?
Photo of David Revel

David Revel

  • 142 Points 100 badge 2x thumb

Posted 9 months ago

  • 0
  • 1
Photo of Evan Martinez

Evan Martinez, Community Manager

  • 8,774 Points 5k badge 2x thumb
HI David,

It is possible to disable Grid Editing in a single table or for a single role in a table. The best way to check this is to go into that tables settings and then the Forms header under settings. From there you can open up the two menus at the bottom for Set how different roles use these forms and Override role settings by report. Both of these menus give you the option to disable Grid Editing whether for every role, a specific role, or a specific list of reports. If you check the attached image below you will see I have standard behavior for Grid Editing set for every role except my Participant role where I have disabled it. I would recommend checking those settings to confirm that none of these dropdowns have been set to disabled. 



Alternatively, this option can also be disabled for a table in a specific roles permissions. You can find this by going into the User table of your application, selecting Manage Roles and then selecting the role you are in. Then if you go to the User Interface tab you can see if the option for Grid Edit has been disabled for your role in that specific table. I hope this information is helpful David. 
Photo of David Revel

David Revel

  • 142 Points 100 badge 2x thumb
Yes this was helpful. I found that this table only did not offer the option to manage forms as you showed. When I added a second form to the list of forms, the choice to manage permissions was displayed and I was able to use the override to allow grid edit. 

I still do not understand why my role (Administrator, App Owner, Company Billing Rep) cannot grid edit this one table as part of the standard behavior. All of the choices in Roles would seem to indicate that I should be able to.