Inconsistent loading of custom pages on mobile

  • 0
  • 1
  • Question
  • Updated 2 years ago
  • Acknowledged
We have an app with a custom HTML page set as the home page.  It'll occasionally load on Android devices with Chrome, but sometimes we get the error shown in the attached photo.  Safari is a no-go, always showing the error in the attached photo.  Has anyone had a similar experience and figured out a way around it?  Thank you all! 

Photo of Christine

Christine

  • 378 Points 250 badge 2x thumb

Posted 2 years ago

  • 0
  • 1
Photo of Matthew Neil

Matthew Neil

  • 31,438 Points 20k badge 2x thumb
I know that sometimes web widgets and Map reports sometimes cause this error on mobile versions.  Just some ideas.  

What kind of things are loading in your custom page?
Photo of Christine

Christine

  • 378 Points 250 badge 2x thumb
Thanks for the speedy response!  It's some HTML and Javascript.  We are making an API call or 2, so not sure if that would affect the mobile rendering.  I'd be less confused if it never worked at all.  It does work intermittently on Android devices.  
Photo of Matthew Neil

Matthew Neil

  • 31,438 Points 20k badge 2x thumb
There are a few .css files that are loaded on the desktop version, that aren't loaded by default on the mobile version.  So that might cause some issues with what is available in your browser cache.  

its hard to tell without diving into the code.  Maybe reach out to whomever made the code page, and they should be able to help.