Is QuickBase compatible with Internet Explorer 11? or Google Chrome 43?

  • 0
  • 1
  • Question
  • Updated 4 years ago
  • Answered

I don't see any update whether QuickBase is compatible with IE 11 or not. Please help me with the information about this. This is urgent.

Thank you.

Photo of Abha

Abha

  • 0 Points

Posted 4 years ago

  • 0
  • 1
Photo of QuickBaseCoach App Dev./Training

QuickBaseCoach App Dev./Training, Champion

  • 65,806 Points 50k badge 2x thumb
Photo of Brenda

Brenda

  • 0 Points
I have IE11 and have had to have the QB help desk help me several times.  It seems that QB does not update as regularly as IE does and therefore cannot keep up with it.  There are several functions that are not compatible with IE 11.