Is there anyway to prevent grid edit report entries on a form in view mode but allow them in add and edit?

  • 0
  • 1
  • Question
  • Updated 2 years ago
  • Answered
I have a parent form (projects) in which I have embedded a child report (requirements).  I want the child report to be a grid edit report us that users can quickly create and edit requirements directly in the parent form.  However, I do not want to allow grid editing of the child report when the parent form is in view mode as the added records are then orphaned and not associated to the parent.  I've tried a number of workarounds including required fields and not checking "Editable" in the field properties when the form is used for view but neither have produced a suitable solution.

Is there a way to display the appropriate records from the child report as read only or as an image in the field when in view mode? 

Any input is appreciated.
Photo of Tom Z

Tom Z

  • 212 Points 100 badge 2x thumb

Posted 2 years ago

  • 0
  • 1
Photo of Eric Mohlman

Eric Mohlman, Employee

  • 400 Points 250 badge 2x thumb
I'm not sure I completely understand. Embedded reports marked "editable" but displayed on a view form will be the view version of that report. It's only on edit or add forms that it turns into a grid edit version. Do you mean then "Grid Edit" link that's on the embedded report?
Photo of Tom Z

Tom Z

  • 212 Points 100 badge 2x thumb
Yes, the grid edit link is available and allows editing of the embedded report even when the the form is in view mode.  When records are entered in this fashion they are not associated with the parent record which creates problems.  I would like to prevent any method of creating orphaned records in the view mode of the form but still display the associated records in the embedded report.
Photo of QuickBaseCoach App Dev./Training

QuickBaseCoach App Dev./Training, Champion

  • 51,036 Points 50k badge 2x thumb
No problem.

Make a new form called "Dummy Form to Block Grid Edit".  Put no fields on the form!

Now that you have multiple forms, go to the forms settings and Forms usage and tell QuickBase which form to use for Grid edit - set that to be the Dummy form.  So while users will still be able to get into Grid Edit, it will be a highly unsatisfying experience as there will be no fields to enter data into.  hence they will not try again.
Photo of Gaurav Sharma

Gaurav Sharma

  • 5,756 Points 5k badge 2x thumb
Great :)
Photo of Eric Mohlman

Eric Mohlman, Employee

  • 400 Points 250 badge 2x thumb
Nice "out of the box" thinking Mark. I like it!

One step further: you could select the form usage for just that embedded report in case any other regular reports need to have their grid edit version still available.
Photo of Tom Z

Tom Z

  • 212 Points 100 badge 2x thumb
Thanks for the quick reply.  However, isn't this solution going to also prevent the users from accessing the actual grid edit form when the parent is in add/edit mode?  In those modes I want the users to be able to grid edit.
Photo of QuickBaseCoach App Dev./Training

QuickBaseCoach App Dev./Training, Champion

  • 51,036 Points 50k badge 2x thumb
I'm not really aware that creating records in Grid Edit in View mode behaves differently than creating child record in edit mode on the Parent.

If that was true, you could have a certain embedded report be used in View mode, and then put the Report link field on the formm a second time and use a different report for it.  Then in forms usage specify a Form override to the dummy form for Grid edit for that report used in view mode. 
Photo of Tom Z

Tom Z

  • 212 Points 100 badge 2x thumb
Thanks again.  I've created this dummy form with no fields.  Then I went to settings>forms>"set how different roles use these forms" and set the value in every row of Grid Edit to this dummy form. When I view a parent record and click on "grid edit" in the embedded child report I'm still able to create orphaned child records.  The dummy form isn't being used.  Am I misunderstanding the solution you suggested?  Again, thanks for your responses.

Update: I see what's happening.  The dummy form is used when a user tries to grid edit main projects page.  It is not used when trying to grid edit the embedded report in the form which is what I am trying to accomplish.
(Edited)
Photo of QuickBaseCoach App Dev./Training

QuickBaseCoach App Dev./Training, Champion

  • 51,036 Points 50k badge 2x thumb
You can set the form override by Role, but also, below that,  by report.  So locate the report that you want to block Grid Edit on.
(Edited)
Photo of Tom Z

Tom Z

  • 212 Points 100 badge 2x thumb
Thanks for your help.  I now have this working and it's an interesting solution.  

There is only one issue that I have left.  My dummy form has no fields assigned to it as instructed. However, the grid edit form that appears has one field (it is the field that links the child records to the parents).  It is possible to edit these which breaks the existing connection to the parent (even though you can't see the other fields in the records).  I looked for a setting in both the original grid edit report and the dummy form that might cause this but haven't been able to resolve it thus far.
Photo of QuickBaseCoach App Dev./Training

QuickBaseCoach App Dev./Training, Champion

  • 51,036 Points 50k badge 2x thumb
Hmmmm, so that one may be a problem.  QuickBase is trying very hard not to let you create orphans.

I have to ask this question which maybe I should have thought about a long time ago.  If you go to the field for [Related Parent] and make the field properties to be Required, would that have solved your whole issue with one click?  You original post was concern that the user would create Orphans.
Photo of Tom Z

Tom Z

  • 212 Points 100 badge 2x thumb
I initially went down the required field path but it was very cumbersome.  The solution with the dummy form and one editable field might be the best one available.
Photo of Matthew Neil

Matthew Neil

  • 31,438 Points 20k badge 2x thumb
Is your "report link" field from the relationship, or did you make it on your own?  Myabe check the target of that report link.  Or include the proxy field for the [related parent] in the embedded reports.
Photo of Eric Mohlman

Eric Mohlman, Employee

  • 400 Points 250 badge 2x thumb
I apologize for not being clear in my explanation yesterday. To demonstrate, I put together an example application and made the Everyone on the Internet group an admin in this app so you can access the settings.

If you view the parent record here: https://team.quickbase.com/db/bmk3z37je?a=dr&r=b you'll see an embedded report on the view form where the "Grid Edit" link is removed. To accomplish this, you need at least two forms on the child table: https://team.quickbase.com/db/bmk3z37jf?a=DFormList for the "Override role settings by report" option to appear. Expanding that section, you'll see that I selected "<Disable>" for the Embedded for Parents report. This specifically disallows that single report from utilizing Grid Edit, but any other table report has it as an option.
Photo of Tom Z

Tom Z

  • 212 Points 100 badge 2x thumb
I was able to replicate this and as far as I can tell it's working as desired.  This has been extremely helpful.  Thanks again!