link from public drive executable in quickbase

  • 38
  • 1
  • Question
  • Updated 6 months ago
  • Answered
I would like to add a link to a quickbase form which users can click for instructions on how to perform that task. We have hundreds of work documents saved on our public drive which we update regularly.



example:

see my attachment. When I click that link, it does nothing. When I copy and paste the link into the browser, my file opens up no problem. Not sure what is stopping quickbase from opening that link.


Photo of mkosek

mkosek

  • 908 Points 500 badge 2x thumb

Posted 5 years ago

  • 38
  • 1
Photo of QuickBaseCoach App Dev./Training

QuickBaseCoach App Dev./Training, Champion

  • 67,278 Points 50k badge 2x thumb
I suspect that this will help



How do I create a hyperlink or URL field that opens a file on my internal network?

QuickBase lets you create URL fields that link to any location you want. You can link to any file on the Web or to a file on your organization's internal (local) network. You link to a local file using one of two field types:

* Regular URL field. If paths to each document will be very different, create a regular URL field that will be completed by users as they add each record.

* Formula - URL field. If the path to the server will remain the same and only the name of the file changes with each record, create a Formula - URL field. When you do so, QuickBase generates the URL automatically based on the file name a user enters.

NOTE: Links to local files work only in Internet Explorer. These links do NOT work in Firefox due to a security setting.


To link from a regular URL field:

Create a URL type field (to learn how, read: https://www.quickbase.com/help/adding_a_field.html) and add it to your table's form(s). Whenever you add or edit a record, type the path to the document in the URL field.

For example, say the path to your document is:

\\ny01\marketing\docs\pamphlet.pdf

Just enter that exact path in the URL field and click Save. When the record's in display mode, that path appears as a link. QuickBase automatically prepends the word "file:" to the URL, which designates the hyperlink as one that opens a destination file on the local network.


To link from a Formula - URL field:

If you store all your documents in the same place, you can save your users some work by using a Formula - URL field instead of a regular URL field. You enter the full folder (or directory) path in the field's properties and then ask your users to enter only the document name. QuickBase will put it all together and generate a proper hyperlink.

First, create a field to hold the file names and add it to your form(s). This can be a text type field. You and your users will use this field to enter the full name of the file you want to link to. When you enter the file name, you must include the file extension (.pdf, .doc, .html and so on) within the name in order for the URL to be complete.

Next, create a Formula - URL type field. After you create the field, click its name to open its properties page. Within the formula box, enter the formula that tells QuickBase how to compose the URL to link to local files.

For example, say the path to the folder containing your documents is:

\\ny01\marketing\docs\

and users will enter filenames in a field called "File Name"

Your formula should look like this:

"file:\\\\ny01\\marketing\\docs\\" & [File Name]

This formula tells QuickBase to take the text that appears between the double quotes (the start of your URL) and add whatever text appears in the File Name field to the end. But, where did those extra backslashes come from? The backslash is a special character in the QuickBase formula language. It tells QuickBase that the character following the backslash should be taken for its true value and not its value in the QuickBase formula language. For example, say you wanted your formula text field to actually include a double-quote character (which, in the formula language delimits the text of a literal). To do so, you'd precede it with a backslash, as in: "The \" character is special." So, for each backslash that you want to actually appear in your URL, you must precede it with another backslash. In other words, double the backslashes--for each single backslash, type two.
Save changes to the field and test it. When you add a record, enter the file name and save. QuickBase then generates a URL that links to that file on your local network.


Read more about:

Creating fields: https://www.quickbase.com/help/adding_a_field.html
QuickBase Formulas: https://www.quickbase.com/help/using_formulas_in_quickbase.html
Photo of mkosek

mkosek

  • 908 Points 500 badge 2x thumb
I feel like this is what I did and it still will not work. If you see my attachment, I was successfully able to put the link onto the checklist. Each checkmark will eventually have its own link associated with whatever the subject may be. All the links will go to a separate file I have saved on our public drive.  The issue I am have is that quickbase does not seem to want to open the URL I created.  If I type in my browser "P:\Masters\ERP 8.5 Instructions\Item Card - Create & Change Revision.docx" the document opens up no problem. when I click the link I created using the exact same URL, nothing happens.  when I copy the shortcut from the link I created, this is what is showing up "file:///P:/Masters/ERP%208.5%20Instructions/Item%20Card%20-%20Create%20&%20Change%20Revision.docx"
Photo of QuickBaseCoach App Dev./Training

QuickBaseCoach App Dev./Training, Champion

  • 67,278 Points 50k badge 2x thumb
Are you using IE or another browser?  this will only work in IE.
Photo of mkosek

mkosek

  • 908 Points 500 badge 2x thumb
ie.
Photo of QuickBaseCoach App Dev./Training

QuickBaseCoach App Dev./Training, Champion

  • 67,278 Points 50k badge 2x thumb
I do not claim to be an expert on this, but are your slashes in the formula forward slashes and they should be back slashes?
Photo of mkosek

mkosek

  • 908 Points 500 badge 2x thumb
I have tried both ways and quickbase automatically changes my formula from "P:\Masters\ERP 8.5 Instructions\Item Card - Create & Change Revision.docx" to "file:/P:\Masters\ERP 8.5 Instructions\Item Card - Create & Change Revision.docx" and when I right click the link & click properties, it shows up as "file:/P:/Masters/ERP%208.5%20Instructions/Item%20Card%20-%20Create%20&%20Change%20Revision.docx"
Photo of mkosek

mkosek

  • 908 Points 500 badge 2x thumb
if I change the URL to www.google.com, the link works fine. It must have something to do with it being a link to a local file. My issue with this is that Quickbase says I can add URL to local files. so why is it not working.  Like is said, if I copy the url right off of quickbase, and paste it into my browser, it works fine. But if I click the link on quickbase, nothing happens.  Why would quickbase change the beginning of my file name to "file:/". This seems to be what is causing it to fail on me.
Photo of QuickBaseCoach App Dev./Training

QuickBaseCoach App Dev./Training, Champion

  • 67,278 Points 50k badge 2x thumb
I'm not  sure what to suggest - I will have to find time to try to test this myself.  I know that I have got it working at some point in the past and it only worked in IE.  Maybe there is an IE security setting that needs to be changed.  You might poke around in that direction.
Photo of QuickBaseCoach App Dev./Training

QuickBaseCoach App Dev./Training, Champion

  • 67,278 Points 50k badge 2x thumb
I just tested this in IE and it works.

This was my formula

"\\\\tor2\\public$\\mark shnier\\" & [File name]


To get the correct file path, I opened a Word document, typed a word and then highlighted and right clicked to insert a hyperlink and browsed to my file on our company's P drive.

Then I right clicked on that hyperlink to get the correct file path (copy hyperlink) and pasted it into IE to check it. It worked. Then I mimicked that hyperlink format in the QB formula, each time putting an extra \ character for each \ that was actually required.

I also tested it in Firefox and as expected it did not do anything.
Photo of mkosek

mkosek

  • 908 Points 500 badge 2x thumb
Thank you everyone for your help. After much trial and error, I was able to narrow it down to a non-quickbase issue. It was an issue with my security settings. This is what I had to do:



Internet options--> advanced tab --> scroll down to security --> make sure “Allow active content to run in files on My Computer*” is checked. Restart IE.

After I did this everything worked great.

Thanks again for all you input!

Photo of mkosek

mkosek

  • 908 Points 500 badge 2x thumb
Also, quickbase needs to be added as a trusted site...also in internet options. (in case anyone else runs into this issue)
Photo of Ruby Kapil

Ruby Kapil

  • 1,050 Points 1k badge 2x thumb
Would like to renew this discussion. I can link file to web based URL but not to a local drive. I tried changing settings in IE and Chrome, but it did not make a difference. Has anyone been able to link to a local drive?

This conversation is no longer open for comments or replies.