Link to the current report

  • 0
  • 1
  • Question
  • Updated 9 months ago
  • In Progress
I have this formula to create a link to the report.

URLRoot() & "db/" & Dbid() & URLEncode("?a=dr&rid=") & ToText([ID])

It works sometimes and sometimes it is blank

Photo of Sarah Bunten

Sarah Bunten

  • 664 Points 500 badge 2x thumb

Posted 9 months ago

  • 0
  • 1
Photo of Ammar

Ammar

  • 312 Points 250 badge 2x thumb
Is the [ID] a formula too? Or is it a related field? What kind of field is it?

Regards
Photo of QuickBaseCoach App Dev./Training

QuickBaseCoach App Dev./Training, Champion

  • 53,240 Points 50k badge 2x thumb
If you are trying to link to a record, the syntax is

URLRoot() & "db/" & Dbid() & "?a=dr&rid=" & ToText([ID])
Photo of Sarah Bunten

Sarah Bunten

  • 664 Points 500 badge 2x thumb
link to record looks like this


But then the email looks like this;

To whom it may concern:

 

Please Note a Supplier Corrective Action Report (SCAR) CAR-1255 has been assigned to you.

 

Finding/ Issue: During customer audit (Sunflower Electric Power) on 11/16/17, customer was inspecting poles in the yard and saw where an improper coating repair had been made.  Action Item 3:       Implement process improvement to prevent coating damage from forklift transportation of pole sectionsAction Item 4 (a):  Repair improper coating repairs.Action Item 4 (b):  Implement process improvement for prevention of improper coating repairs.

 

To complete the Corrective Action click on this Link: https://trinityindustriesinc.quickbase.com/db/bmpb6z9v9?a=dr
Photo of Ammar

Ammar

  • 312 Points 250 badge 2x thumb
The link is missing "&rid=[Record ID#]"

if this is being sent through notification, you would need to encode it!

Regards 
Photo of Sarah Bunten

Sarah Bunten

  • 664 Points 500 badge 2x thumb
at the end?
Photo of Ammar

Ammar

  • 312 Points 250 badge 2x thumb
Yes,
This is what is the [Link to record] code:
URLRoot() & "db/" & Dbid() & "?a=dr&rid=" & ToText([ID])

Your link is :
https://trinityindustriesinc.quickbase.com/db/bmpb6z9v9?a=dr


Which is missing the bold part
Photo of Sarah Bunten

Sarah Bunten

  • 664 Points 500 badge 2x thumb
Doesn't work.  Solution was what I originally had.  It had a small glitch


URLRoot() & "db/" & Dbid() & URLEncode("?a=dr&rid=") & ToText([ID])
Photo of Sarah Bunten

Sarah Bunten

  • 664 Points 500 badge 2x thumb
what am i doing wrong here?

Photo of Sarah Bunten

Sarah Bunten

  • 664 Points 500 badge 2x thumb
The link is correct but when i put it in the body:
"Please Note a Supplier Corrective Action Report (SCAR) " &[CAR ID] & " has been assigned to you."&
"%0D%0A" &
"%0D%0A" &
"Finding/ Issue: " &[Finding / Issue                                                                                                                           _] & 
"%0D%0A" &
"%0D%0A" &
"To complete the Corrective Action click on this Link: " &
[Link to record] &
"%0D%0A" &
"%0D%0A" &
"If you have any questions please reply to this email."&
"%0D%0A" &
"%0D%0A" &
"Thank you!"


That then gets put into the email to the supplier:
"mailto:"&""&[Supplier E-Mail Address]
&"\n"&"?Subject="&"\n"&[Subject]
&""&"&body="&"\n"&[Body]

Something goes wrong.
Photo of QuickBaseCoach App Dev./Training

QuickBaseCoach App Dev./Training, Champion

  • 53,240 Points 50k badge 2x thumb
What’s is the code that was clicked that gave that message. It is saying that you are asking to rerun a report which does not exists.
Photo of Sarah Bunten

Sarah Bunten

  • 664 Points 500 badge 2x thumb
Inside field [Body]:
"To complete the Corrective Action click on this Link: " &
[Link to record] &
"%0D%0A" &
"%0D%0A" &


This is the email:
That then gets put into the email to the supplier:
"mailto:"&""&[Supplier E-Mail Address]
&"\n"&"?Subject="&"\n"&[Subject]
&""&"&body="&"\n"&[Body]
Photo of Ammar

Ammar

  • 312 Points 250 badge 2x thumb
What is the code of [Link to record]?
Photo of Sarah Bunten

Sarah Bunten

  • 664 Points 500 badge 2x thumb
URLRoot() & "db/" & Dbid() & "?a=dr&rid=" & ToText([ID])