Multiple Table Report

  • 0
  • 1
  • Question
  • Updated 3 years ago
  • Answered

I would like to build a report using 3 tables.

Services

Profiles

Goals

I am creating the report in the services table.  The table to table relationship for Profiles and Goals says one Profile/Goal can have many services. I have selected all of the fields that I want to use in the report as lookup fields.

The report worked....Kind of...

The report shows all of the services and all of the related profiles.. but for some reason the Goals don't seem to be connecting to the report.  In other words the Goal Columns are on the report table, but no information is populating in those columns.  

I am using a table report and using custom columns, only selecting the columns for the data that I want to show.

The student name that all of this information ties back to is the first column on the report table.

Thanks!

Photo of TIm

TIm

  • 90 Points 75 badge 2x thumb

Posted 3 years ago

  • 0
  • 1
Photo of QuickBaseCoach App Dev./Training

QuickBaseCoach App Dev./Training, Champion

  • 62,944 Points 50k badge 2x thumb
If you look at a record on the Services table, are those those blank fields populated?   If not does that record have a selection made for the Related Goal?  If so, does that Goal record have data populated for the field that he lookup field is pulling?
Photo of TIm

TIm

  • 90 Points 75 badge 2x thumb
The Goals are populated on the Goals table.  For some reason they are not appearing populated on the Services table, however..  Does this sound like my relationships are incorrect?  I'm not sure why its working for one table, but not the other.  The table that it is working for, is using check boxes and text fields.  The Table that isn't working is utilizing a multiple choice field.
Photo of QuickBaseCoach App Dev./Training

QuickBaseCoach App Dev./Training, Champion

  • 62,944 Points 50k badge 2x thumb
I would check the fields that define the relationship like Related Goal and see if you see it on the Services record in edit mode. I suspect that the Service a records are in fact not connected to a Goal. I.e., Related Goal is blank.