Newly Created Table and Fields-Fields are not showing up

  • 0
  • 1
  • Question
  • Updated 1 year ago
  • Answered
I recently created a 4th table in an application.  I used the "clipboard" function to paste in all my fields I wanted under the import/export function.  When i go to add new customer(my green button top right) none of my newly added fields are showing up.  When I go into settings and fields I see them all thee.  Why aren't they showing up?

THANK YOU!
Photo of Eric

Eric

  • 60 Points

Posted 1 year ago

  • 0
  • 1
Photo of QuickBaseCoach App Dev./Training

QuickBaseCoach App Dev./Training, Champion

  • 51,436 Points 50k badge 2x thumb
No problem,
Customize the form and add the new fields to the form
Photo of Eric

Eric

  • 60 Points
Where do I do this at?  Settings, Fields?
Photo of Chris

Chris, Champion

  • 4,380 Points 4k badge 2x thumb
"Customize this form" should show at the top right when you open a single record for viewing or editing.
Photo of Chris

Chris, Champion

  • 4,390 Points 4k badge 2x thumb
Sounds like you may have inadvertently bypassed the option to add new fields upon import. QB does allow you to create new fields as you import new data.
Photo of QuickBaseCoach App Dev./Training

QuickBaseCoach App Dev./Training, Champion

  • 51,436 Points 50k badge 2x thumb
One way is to View any record and then at the top right "Customize this form".

or else in Settings for the table and Forms.
Photo of Eric

Eric

  • 60 Points
Guys Im not tracking.  Is there somewhere where I need to check a box to "add fields to the form"
Photo of Chris

Chris, Champion

  • 4,380 Points 4k badge 2x thumb
Open up any record in view mode or edit mode. Then, at the top right of your view ( assuming you're an admin and have permission to modify forms ) you should see the text link "Customize this form" with an image of a spanner next to it. Do you see that link when you open a single record in view or edit mode? Or even in Add mode?
(Edited)
Photo of QuickBaseCoach App Dev./Training

QuickBaseCoach App Dev./Training, Champion

  • 51,436 Points 50k badge 2x thumb
If you have Administrator rights to the app, then you will see "Settings" at the top left when you are on the table. Only Admins can add field to a form.
Photo of Eric

Eric

  • 60 Points
yes I am an admin, and yes I can see "customize this form".  When i click on it, non of my fields are showing up
Photo of Chris

Chris, Champion

  • 4,380 Points 4k badge 2x thumb
Right, so you use that interface to select them from the left hand side, "Form Element". You'll see drop down lists. Select the fields from there.
Photo of Chris

Chris, Champion

  • 4,390 Points 4k badge 2x thumb
When you click settings on a table view, you will see Forms in the middle column, bottom row. Click that and you will see your form or forms.
Photo of Eric

Eric

  • 60 Points
I just deleted them all and reimported and added the fields to the form from there.

Thanks Guys!