Number Format of Field not transferring to exact form.

  • 0
  • 1
  • Question
  • Updated 2 years ago
  • In Progress
The auto-generated File Number - [Record ID#]+150000, in the database is formatted as formula numerical with no decimal places and no commas. Example 123456. When I insert the field in an exact form, it appears as 123,456. How do I format that number in the exact form to remove the comma?  Changing the formula to ToText([Record ID#]+150000) does not work.  Can I change the formatting directly in the HTML page?
Photo of bgstatdex

bgstatdex

  • 270 Points 250 badge 2x thumb

Posted 2 years ago

  • 0
  • 1
you might try changing the field from formula numeric to formula text, or looking at the field settings and changing the display format to: period decimal mark; 12345678.00 with 0 decimal places. 

let me know if that helps.
Photo of bgstatdex

bgstatdex

  • 270 Points 250 badge 2x thumb
This is a field that automatically assigns each file a file number starting at 150000.  [Record ID#]+150000.  I don't think a formula text field will accomplish what we are trying to do.  The first file opened is 150001 then 150002, etc.  Doesn't this have to be a number?  Like I said before, I tried ToText([Record ID#]+150000) and that didn't work.
the exact form is seeing that value as a number and may be adding the comma based on default handling of numbers. So that is either because it is a number field where comma's are turned on in the field settings, or because the data is spitting out as a number to the document. 

You can create a formula text field that returns a text result of a numeric value. You probably can not have a formula numeric field that will allow you to use the totext function. However, you may use a formula text field that converts numbers into text using totext. 

For example, a zip code in the US is made up of numbers. Boston has a zip code: 02110. If that was recognized as a number, it would show as 2110, droping the 0. However, if you use a text field, it understands that the first 0 is to be a text character and not treated as a number.
 
So my recommendation is to first, try looking at your field settings to see if the output is set to allow commas. If it is, turn that off. If that doesnt solve the problem, convert the field to a formula text field... that should work.