Open a newly created Record in Edit Mode

  • 0
  • 1
  • Question
  • Updated 3 years ago
  • Answered

I have a button on several tables that adds information to a new table. The formula allows me to create a new record in a separate table with all the correct information already filled in. There is just one field I need employees to fill out on the new table. However, my formula automatically creates a new record and brings the employee to the alreaady saved record in view mode. Therefore, requiring the field does not do anything because they do not need to save. 

Is there a way to create and then open the new record in EDIT mode? 

Here is the formula

URLRoot() & "db/" &[_DBID_EMPLOYEE_TASKS] & "?act=API_addRecord"

& "&apptoken=c8usqfibak5cz4c2vx5fhdh7c9dv"

& "&_fid_6=" & URLEncode([Subject])

& "&_fid_10=" & URLEncode([Description])

& "&_fid_37=" & URLEncode([Project Name])

& "&_fid_38=" & URLEncode([Project Task - Project Name])

& "&_fid_7=" & URLEncode([Date])

& "&disprec=1"

Photo of Amanda

Amanda

  • 10 Points

Posted 4 years ago

  • 0
  • 1
Photo of Joseph

Joseph

  • 0 Points
Hi Amanda,



Try this and see if it works:



URLRoot() & "db/" &[_DBID_EMPLOYEE_TASKS] & "?act=API_addRecord"

& "&apptoken=c8usqfibak5cz4c2vx5fhdh7c9dv"

& "&_fid_6=" & URLEncode([Subject])

& "&_fid_10=" & URLEncode([Description])

& "&_fid_37=" & URLEncode([Project Name])

& "&_fid_37=" & URLEncode([Project Task - Project Name])

& "&_fid_38=" & URLEncode([Project task Name])

& "&_fid_7=" & URLEncode([Date])

& "&rdr=" & URLEncode(URLRoot() & "db/" &[_DBID_EMPLOYEE_TASKS] & "&er&rid=" & [Record ID#])

Joe Y

QuickBase Cares Team
Photo of QuickBaseCoach App Dev./Training

QuickBaseCoach App Dev./Training, Champion

  • 59,768 Points 50k badge 2x thumb
I don't see how that can work.  At the moment the button is pushed, the URL is frozen and the [Record ID#] of the newly created record dies not exist and it's unknowable at that point.
Photo of Amanda

Amanda

  • 10 Points
Someone from Customer Support actually helped me. All we had  to do was change :act=API_addRecord" to "act=API_GENaddRecordFORM" It was that simple!
Photo of QuickBaseCoach App Dev./Training

QuickBaseCoach App Dev./Training, Champion

  • 59,768 Points 50k badge 2x thumb
Duh, yes!
Photo of Amanda

Amanda

  • 10 Points
Yea... I tried "EditRecord" and "GenRecord" but just couldn't pull together the other pieces by myself haha! Thanks for the help Quickbase team!