QuickBase Action returning error "invalid user token"?

  • 0
  • 1
  • Question
  • Updated 8 months ago
  • Answered
I'm confused, anyone have any ideas?
Photo of Manny De La Cruz

Manny De La Cruz

  • 940 Points 500 badge 2x thumb

Posted 2 years ago

  • 0
  • 1
either the user token is missing, is not entered correctly, or that user that the user token belongs to does not have access to the app.
Photo of QuickBaseCoach App Dev./Training

QuickBaseCoach App Dev./Training, Champion

  • 53,570 Points 50k badge 2x thumb
OK, so I'm curious abut this one too.  So Actions are like Webhooks for Dummies.  ie low code.  When I set up Actions, they do not refer to usertokens at all.
Well, you are correct Mark. I somehow didn't pay attention to 'Action' I assumed webhook because of user token.

I just tested an action and it worked without any error like this.

I wonder if there is some other error and QuickBase is sending a false error description? Interesting.
Photo of Manny De La Cruz

Manny De La Cruz

  • 940 Points 500 badge 2x thumb
To clear up the scenario. I downloaded an app from the exchange 'ABC Customers Update Their Own Records" - (One of Kirk's many awesome apps with crazy cool features). Brief summary of it; sends an E-Mail to someone with no QB Account with a button to a form that the person fills out. This all happens with Quickbase actions magic; just to not go in depth.

I am now the app owner, so should the token be correct? Maybe he is still the owner of the Action..? 
Quick Base is the owner of the action. My guess is that duplicating the action and killing the other one would resolve the problem.
Photo of QuickBaseCoach App Dev./Training

QuickBaseCoach App Dev./Training, Champion

  • 53,570 Points 50k badge 2x thumb
I would try duplicating the ACTION (there is an icon for that), Then kill the other one.  That may fix it.  failing that, then try recreating it from scratch.  Just open two screens and look back and forth.
Photo of Manny De La Cruz

Manny De La Cruz

  • 940 Points 500 badge 2x thumb
Thanks, guys! I tried duplication first, it didnt work, but when I went from scratch it did. Who knows why, but it works, so all good. Thanks again!
Photo of QuickBaseCoach App Dev./Training

QuickBaseCoach App Dev./Training, Champion

  • 53,570 Points 50k badge 2x thumb
I assume that because ACTIONS are Webhooks for Dummies, they are really webhooks wrapped in a pretty package.  So some how they automated that usertoken thing with in itself is not obvious.  

It also probably means that if you copy an app, all the ACTIONs might break.  i have not tested that.
Photo of Matt NZ

Matt NZ

  • 296 Points 250 badge 2x thumb
Same thing happens to me on my own apps that I have copied within my realm.
Copying the ACTION still has the "invalid user token" error.
Creating a new ACTION from scratch works fine.

It seems that all ACTIONs break when I copy an app, and for every ACTION, I need to recreate a new one to replace the old one.