QuickBase Sync - User List field displays email

  • 0
  • 1
  • Question
  • Updated 3 years ago
  • Answered

I have a table "Clients" in App 1 which has List-User fields to assign account managers to the clients.This table is replicated in App 2 using QuickBase Connection. 

In the App 2 Clients table, the fields for users shows up as text with the email in quare brackets "[email@email.com]". Empty items shows up as "[]". This is not good especially when creating reports that are based on current user since the current user looks for full name.

What are my options? 

Is there a way to sync the table such that the User is maintained same was as original table? OR

What can I use in a report to query based on current users email? I tried contains "usertoemail(_curuser) and it didn't work

Photo of Priyanka

Priyanka

  • 0 Points

Posted 3 years ago

  • 0
  • 1
Photo of QB_Support_Brian

QB_Support_Brian

  • 40 Points
Hi Priyanka,

The display of List - User fields in a connected table is displaying email addresses on my end as well. The best thing to do is to open a support case by going to Help > Manage Support Cases > + New Support Case. A customer care specialist will reach out to you to investigate.




Thank you,

Brian
Photo of Jack

Jack, Champion

  • 50 Points
I too have come across this too and believe its a bug.
I created a formula email field called email in the primary table (the original table) and used the formula UserToEmail([User Field]) then pulled the email field through the sync and then created a formula user field in the synced table called User and used ToUser([Email Field])
You could then use this user field in your reports until this problem is fixed or leave the workaround in.