Random filter added to Embedded Reports on only SOME records

  • 0
  • 1
  • Question
  • Updated 4 years ago
  • Answered
Has anyone ever encountered this? I have a support ticket in because I think it is a bug but thought I would check here as well.

I have an embedded report that is on all the RFP records. On some of the records the embedded report randomly assigns a filter (on one project that filter was the number 3, on another one any project ID that contained the number 8). When I go to update the report I can remove the filter on those projects (but it reappears after save), and when I try to edit the report from the form or from the settings area there is no filter listed!
Photo of Leanne

Leanne

  • 262 Points 250 badge 2x thumb

Posted 4 years ago

  • 0
  • 1
Photo of QuickBaseCoach App Dev./Training

QuickBaseCoach App Dev./Training, Champion

  • 59,576 Points 50k badge 2x thumb
99% sure what is happening.  Your users are popping up "Full Version" on the embedded report.  They then play with the convenient Dynamic filters  and SAVE the report, thus changing the main saved copy of that embedded report.  The solution is to remove access from users or at least most of them so that they do not have permission to save "Common" reports.  Have them make Personal reports and send you the URLs when they want one saved as a Common Report.
Photo of Leanne

Leanne

  • 262 Points 250 badge 2x thumb
Thanks for the quick response, but since my users do not have access to change common reports, that was not it. The actual issue was that in the report link field the box "Only include values if they match exactly in both fields" was somehow unchecked. Hopefully this will help others if it happens on their reports!
Photo of Jamie

Jamie

  • 0 Points
This actually just happened to me and this was extremely helpful!!!! To add a bit of clarification though, to get to this field, you can navigate to it from the properties button in form edit - though I'm sure not the only way.