Record ID displaying in lookup field

  • 1
  • 2
  • Question
  • Updated 1 year ago
  • In Progress

I decided to create a new clean app to avoid propagating some of the learning mess I'd had in my first app. However I'm having issues with the record ID instead of proxy field showing up, as below;

 I've checked back to my original app (where the lookup worked fine) and I cannot see any differences in the settings.

The related site field settings are as below;

I haven't copied in the screenshots of the original apps table relationships but they are exactly the same (unless I've been staring at these long enough that I can't see the differences!).

Any ideas?

Photo of Mark

Mark

  • 300 Points 250 badge 2x thumb

Posted 1 year ago

  • 1
  • 2
No problem.
Go to the Settings for the table which holds the drop down source and to Advanced Properties.  

Set the Record Picker fields.  These are the fields that you set to show by default to allow uses to "pick" which records they want in a drop down list from a relationship.
Photo of Mark

Mark

  • 300 Points 250 badge 2x thumb

Thank you!  I knew it was going to be in a menu I hadn't looked at yet :)

Are the record picker fields created when you create the table for the first time or the relationship for the first time?  Just wondering if there is a default period when you can first chose these pickers to avoid having to edit later.

The Record Picker fields really have nothing to do with relationships.  They tend to get selected when the first fields are created in he table on the assumption that the first two fields you create must be the most important identifier of the records.  The first default field will be the [Record ID#] field and then the next two fields you create will the the next two slots in the record picker. 

The record picker fields are also used when you click on the "star" at the top right to look at recently touched records.
Photo of Mark

Mark

  • 300 Points 250 badge 2x thumb
Got it, thanks!  I'd added fields for site address and similar before I got to site id, so that's where this came from, I'll remember to keep an eye out for this one in the future!
Right, and the other good housekeeping practice once most of he fields are set up is to set the default report, so get the best default fields, Dynamic filters and sort. 

That will save a ton of time and frustration as you work with the app, if you get your default reports cleaned up and disable to auto add fields to the default report.

Settings (for the table)
Reports, and then way up at the top right for defaults. 
Photo of Mark

Mark

  • 300 Points 250 badge 2x thumb

I did that one but by creating new "main" reports (since I wanted to leave the ALL reports alone) and then assigning these main reports as the default report, but thank you for the official method of doing this, less clicks in the future!

One other quick one, normally you edit the field value to remove the, for example, <add a new site> option (via "allow users to create new choices") but I can't remember where this option is for lookup fields?  I'm pretty certain that also includes what information to display in the drop down (ie. record ID# + site ID or just site ID).  I've been hunting but can't remember where this option is, can you point me the right way?

(Edited)
It’s a Permission issue. If the user is in a Role which allows Adding records, then they will have the option at the bottom of the record to Add record.

I’m not sure if simply changing the Role to Hide the Add Record button would apply to the link at the bottom of the drop down list.
Photo of Mark

Mark

  • 300 Points 250 badge 2x thumb

Got it, thanks!

And can you remember where the settings are for adjusting what's displaying in the dropdown choices?  ie. record ID# + site ID or just site ID