Related record as number

  • 0
  • 1
  • Question
  • Updated 3 months ago
  • Answered
In view mode, related record appears as a record number but in edit mode, I can choose a record from the drop down. How to show record using field value instead of the record number?  I am showing the field normally on the form. 
Photo of Arshad Khwaja

Arshad Khwaja

  • 3,142 Points 3k badge 2x thumb

Posted 2 years ago

  • 0
  • 1
Photo of QuickBaseCoach App Dev./Training

QuickBaseCoach App Dev./Training, Champion

  • 62,316 Points 50k badge 2x thumb
The magic here is the use of a Proxy field for the field typically called [Related Parent].

For example, if you have a table of Stores and the key field is [Record ID#], but the [Record ID#] is meaningless to the users.  You bring down the Store name in a lookup field on the relationship, and then edit the field properties for the [Related Store] record to select Store Name as the Proxy field.

Then on the form, you use [Store Name] and not [Related Store].  In View mode the field on the form will have as [Store Name], but in edit mode it will behave as [Related Store] allowing the user to select the [Record ID#] of the Parent Store record.
Photo of Steve Hanson

Steve Hanson

  • 114 Points 100 badge 2x thumb
This trick didn't work at first, but it was my fault. Before finding this solution, I thought the problem was that the field was set to numeric so I changed it to text, thinking it would show the record name and not the number. I ran your trick and it did nothing. I changed the type back to numeric and voila! Thank you! 
Photo of Arshad Khwaja

Arshad Khwaja

  • 3,142 Points 3k badge 2x thumb
Thanks.  I have the field set up as you have advised but for some reason I still see a number in view mode.  Pl see the default admin form I have for your perusal. A screenshot of how it appears is
attached. 




 attached. 
Photo of QuickBaseCoach App Dev./Training

QuickBaseCoach App Dev./Training, Champion

  • 62,316 Points 50k badge 2x thumb
I do not see the Store name field in the form. I see a yellow field which looks like a hyperlink field

If you don't want to show the [Record ID] field in View mode, then change the form settings to only show in edit and add mode