Remove HTML from URL field

  • 0
  • 1
  • Question
  • Updated 2 years ago
  • Answered
Hi!

I have set up a URL formula that will be embedded in email notifications and sent to clients. I have done some customisation to the button in the notification and written all the HTML there. It looks something like this:

<a href="[quickConfirmURL]" style="background-color:#37A637; border:1px solid #2F8C2F; border-radius:2px; color:white; display:inline-block; font-family: Roboto, Open sans, Helvetica, Arial, sans-serif; font-style: normal; font-size:12px; font-weight:normal; height:29px; line-height:29px; min-width:54px; outline:0px; padding:0 8px; text-align:center; text-decoration:none" target="_blank">CONFIRM JOB</a>

When I add the field to the email it brings with it the opening "<a href=" and closing "</a>". I have tried text fields and URL fields and it seems that either way if Quickbase detects a url it adds the "<a href=" and "</a>" tags. Is there any way to avoid this?

Thanks!
Photo of Lochlan Broughton

Lochlan Broughton

  • 224 Points 100 badge 2x thumb

Posted 2 years ago

  • 0
  • 1
Photo of Chuck Grigsby

Chuck Grigsby

  • 2,100 Points 2k badge 2x thumb
Try formula text field with allow HTML tags option checked.
Photo of Lochlan Broughton

Lochlan Broughton

  • 224 Points 100 badge 2x thumb
I tried everything, except that! This works. Thank you, Chuck. And thanks for the fast reply.
Photo of Chuck Grigsby

Chuck Grigsby

  • 2,100 Points 2k badge 2x thumb
Happy to help!
Feel free to reach out if you have any other questions.
Chuck@chuck.support
Chuck.support/donate