Summary Report not grouping

  • 0
  • 1
  • Question
  • Updated 3 months ago
  • Answered
Hey folks, got a problem over here. I've made a summary report that is supposed to group by business unit. And for some reason, it is not. 

For example, if I were tracking car sales, it should show something like this: 

Brand.....Sales.....Total Dollars
Buick......4............$80,000
Chev.......10..........$150,000
GMC.......2...........$100,000


Instead, I'm getting this: 
Buick.....3...........$70,000
Chev......5...........$100,000
Chev......2............$25,000
GMC......1............$60,000
Buick....1..............$10,000
GMC.....1..............$40,000
Chev......3.............$25,000


Some troubleshooting that I've already done:
  • In a grid edit, copied and pasted from one cell to all the others to ensure that the Brand is exactly the same for each of the like brands
  • Changed my grouping from Brand to type (i.e. SUV or Convertible); that one worked correctly--along with a different grouping that I did (call it manual or automatic)
  • When you click on any of the groups for the drilldown report, it is showing everything. So I could click on the "Chev 3" line and the drilldown report takes me to all 10 Chevs sold. 

Any idea why this isn't working? We do have some filters in place, but they should NOT be causing any of these problems. 
Photo of mtn

mtn

  • 102 Points 100 badge 2x thumb

Posted 3 months ago

  • 0
  • 1
Photo of QuickBaseCoach App Dev./Training

QuickBaseCoach App Dev./Training, Champion

  • 65,332 Points 50k badge 2x thumb
I'm wondering if there is some weirdness with leading or trailing spaces in the Brand field.  A quick way to test that you be to make a formula field Trim([Brand]) and group on that field.
Photo of mtn

mtn

  • 102 Points 100 badge 2x thumb
Wouldn't that have been remedied by copying and pasting within the grid edit? 

What I mean by that is I copied the first "Chev" entry, and pasted it into every other "Chev" brand spot. 

EDIT: GOing to try that though 
(Edited)
Photo of mtn

mtn

  • 102 Points 100 badge 2x thumb
Trim worked. Thanks!

Any ideas why it is doing this though? These aren't manually entered, they're from a drop down.
Photo of QuickBaseCoach App Dev./Training

QuickBaseCoach App Dev./Training, Champion

  • 65,332 Points 50k badge 2x thumb
There must have been data entered earlier by import or free form before the drop down.  Or maybe the drop down had a space in it and was later corrected after some data was entered.

I don't know how much data you have but a complete grid edit copy and paste or fill down should clean that up too.