The fields I want to use for dynamic filters aren't showing as available. How do I change that?

  • 0
  • 1
  • Question
  • Updated 2 years ago
  • Answered

I go to default dynamic filters, and the fields I want to use are not in the available box on the left.  What do I need to change so these become available?

Photo of Heather

Heather

  • 0 Points

Posted 4 years ago

  • 0
  • 1
The Help text here  http://www.quickbase.com/user-assistance/Default.html#dynamic_filters.html  near the bottom explains which field types are available as Dynamic filters. In general,  formula fields for example, are not eligible.  You also need to ensure that the field(s) you want are set to be searchable in their field properties.
Photo of Ron Ruetz

Ron Ruetz

  • 170 Points 100 badge 2x thumb
What if the searchable box is checked, but still does not show in the dynamic filters available.
Numeric fields are not eligible as DFs.  If you need them to be make a new formula text field like

ToText([my numeric field])
Photo of Ron Ruetz

Ron Ruetz

  • 170 Points 100 badge 2x thumb
Thanks for your reply, but it's not a numberic field.  It's a Text field that simply says Salesperson. 
So it is a plain text data entry field?
Photo of Ron Ruetz

Ron Ruetz

  • 170 Points 100 badge 2x thumb
Yes, I sent a screen shot of what I am looking at.
Photo of Ron Ruetz

Ron Ruetz

  • 170 Points 100 badge 2x thumb
Is there another setting somewhere I am missing?
Multi line text fields are not eligible as a DF.  Can you change it to be a single line text field.  It is also unusual to have a sales rep be a free form data entry field.

I suggest changing this to a either a single line text field or a Multi select field type.  Both are valid as DFs
Photo of Ron Ruetz

Ron Ruetz

  • 170 Points 100 badge 2x thumb
Thanks!!  That worked.
Which did you go with?  multi select or text?
Photo of Ron Ruetz

Ron Ruetz

  • 170 Points 100 badge 2x thumb