Trouble Saving a Record on Mobile Device - Anyone Else Have This Issue

  • 0
  • 1
  • Question
  • Updated 3 weeks ago
  • Answered
  • (Edited)
I have a very lengthy form with over 100 fields and 70 form rules (many derived-field related) that works just fine on desktop, but I cannot save on a mobile device (without forcing it to desktop version).

I click Save and a small purple logo pops-up on screen briefly (think hourglass or spinning wheel), but then it goes away and I'm still on the form as though I never clicked save - and consequently a record is not created.

On my main form (for desktop) I have a custom save button that redirects the user to a different page when the record is created.  Using this form on a mobile device that button only redirects me, it doesn't save the record.

So I created a mobile form where I have removed that button and use the native buttons, but still no results.

I've even tried changing the default form for everything (Add/Edit/View/Mobile) to the mobile form, and it saves in desktop but not on a device.

I've tested my device on other apps for mobile, and they work just fine.  It just doesn't seem to like this app.

Anyone else having trouble with mobile?  Did I break Quick Base?
Photo of Eric Evans-Vargas

Eric Evans-Vargas

  • 586 Points 500 badge 2x thumb

Posted 5 months ago

  • 0
  • 1
This sounds very odd, I'd recommend submitting a ticket with these details to Quick Base support. They tend to respond very quickly.

I have personally noticed different (and occasionally buggy) experiences on mobile too. See this other tread on a related mobile topic https://community.quickbase.com/quickbase/topics/refresh-parent-record-after-child-is-created

-Sharon
(Edited)
Photo of Eric Evans-Vargas

Eric Evans-Vargas

  • 586 Points 500 badge 2x thumb
Thanks Quick Base Junkie!

I opened a ticket with them as well ... and they're looking into it.
I figured I'd post here too, to see if anyone else was experiencing something similar.
Great! Let us know what you discover.
Photo of Ana Bar

Ana Bar

  • 70 Points
I don't know if it's the same issue that I was struggling with, or if you already solve your problem, but it seems that the mobile version have some problems when there's special characters on the fields. In my case was with the accent marks (I write in Spanish). Once I erase this characters it saved just fine. I'd like to read your update.